Si plage contient du texte alors .... [Résolu/Fermé]

Signaler
-
 KAWTAR -
Bonjour,

Mon problème:

j'ai une plage de cellule avec soit du texte soit des chiffres, j'aimerais que lorsqu'il y a quelque chose dans au moins une cellule de cette plage il y ai un "X" qui apparait mais si il y a rien je veux que rien ne s'affiche.

merci pour vos réponses
A voir également:

2 réponses

Messages postés
25945
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 avril 2021
5 862
Bonjour
en B1 si on commence en A1:

=SI(A1="";"";"X")

crdlmnt
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

merci pour la réponse mais j'aimerais que ceci fonctionne pour une plage de cellule

ex: =SI(A1:E1="";"";"X")

des solutions ?
Messages postés
25945
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 avril 2021
5 862
=SI(NB.SI(A1:E1;"")=5;"";"X")
ou encore:

=SI(NB.SI(A1:E1;"<>");"X";"")
magnifique merci infiniment. depuis toute l'après midi je cherchais ça. juste pour ma curiosité, à quoi sert le chiffre 5 dans la formule ?
Messages postés
25945
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 avril 2021
5 862
la 1° formule compte le nombre de cellules vides entre A et E et donc si le résultat est égal a 5 (soit A,B,C,D,E) elle ne doit pas renvoyer X
la 2° formule elle, détecte si une ou plusieurs cellules contiennent une valeur quelle qu'elle soit et donc renvoie X si elle en trouve au moins une
si OK, merci de passer le sujet en résolu (menu roue entée à droite du titre du fil en haut)
bonne route
crdlmnt
merci pour toutes ces réponses
Bonjour,
Je suis à la recherche d'une fonction qui me permettra de savoir si le contenu d'une cellule (Un long texte avec espaces) existe dans une plage sur une autre feuille excel.

Je vous remercie de votre retour.