Si plage contient du texte alors ....

Résolu/Fermé
sim - 24 mai 2018 à 18:03
 KAWTAR - 21 mars 2019 à 11:17
Bonjour,

Mon problème:

j'ai une plage de cellule avec soit du texte soit des chiffres, j'aimerais que lorsqu'il y a quelque chose dans au moins une cellule de cette plage il y ai un "X" qui apparait mais si il y a rien je veux que rien ne s'affiche.

merci pour vos réponses

2 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 254
24 mai 2018 à 18:16
Bonjour
en B1 si on commence en A1:

=SI(A1="";"";"X")

crdlmnt
3
merci pour la réponse mais j'aimerais que ceci fonctionne pour une plage de cellule

ex: =SI(A1:E1="";"";"X")

des solutions ?
-1
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 254
Modifié le 24 mai 2018 à 19:12
=SI(NB.SI(A1:E1;"")=5;"";"X")
ou encore:

=SI(NB.SI(A1:E1;"<>");"X";"")
0
magnifique merci infiniment. depuis toute l'après midi je cherchais ça. juste pour ma curiosité, à quoi sert le chiffre 5 dans la formule ?
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 254
Modifié le 24 mai 2018 à 19:21
la 1° formule compte le nombre de cellules vides entre A et E et donc si le résultat est égal a 5 (soit A,B,C,D,E) elle ne doit pas renvoyer X
la 2° formule elle, détecte si une ou plusieurs cellules contiennent une valeur quelle qu'elle soit et donc renvoie X si elle en trouve au moins une
si OK, merci de passer le sujet en résolu (menu roue entée à droite du titre du fil en haut)
bonne route
crdlmnt
0
merci pour toutes ces réponses
0