[EXCEL] - Attribuer une valeur numérique à un mot [Fermé]

Signaler
-
 Stev28fr -
Bonjour,

Je ne trouve pas la formule...
Le problème j'ai deux colonnes une avec une liste déroulante avec 4 valeurs (R, S1, S2, S3) et attribué une valeur numérique (1,2,3,4) qui s'affiche dans la case au choix en fonction de la sélection.

Merci de votre aide !

5 réponses

Messages postés
26102
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 juillet 2021
5 988
Bonsoir
plusieurs options:
1°)formule avec condition, pour un texte en A2, formule en B2:
=SI(A2="R";1;SI(A2="S1";2;SI(A2="S3";3;SI(A2="S4";4;""))))

ou, si vos valeurs sont réellement 1,2,3,4

écrire en Z1: R en Z2 S2; en Z3:S3 en Z4:S4
et la formule est:

=SIERREUR(EQUIV(A2;$Z$1:$Z$4;0);"")

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
790
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
16 juillet 2021
143
Bonsoir

Pas sûr d'avoir bien compris, voir pièce jointe

https://www.cjoint.com/c/GCjugd2tnzj

Slts
Merci pour votre aide ! Oui c'est exacement ça sauf que les valeur sont les suivante j'ai essayer de coprendre mais pas simple ...

Mais les valeurs sont :
R => 0
S1 => 110
S2 => 80
WE => 130
BLP => 60

Merci pour votre aide car je ne comprend pas le code :/ !
Messages postés
790
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
16 juillet 2021
143
Bonsoir,

Quand tu dis c'est exactement ça, tu parles de la proposition de Vaucluse, ou la mienne?

Ci-joint une version modifier avec les nouvelles valeurs + colonne G et H visible avant ses deux colonnes étaient masqués

https://www.cjoint.com/c/GCjvYTHtnMj

Slts
C'est bon ! j'ai réussi en essayant de comprendre le fichier et avec votre exemple !
Merci pour votre rapidité !