[EXCEL] - Attribuer une valeur numérique à un mot

Fermé
Stev28fr - 9 mars 2017 à 19:48
 Stev28fr - 10 mars 2017 à 09:30
Bonjour,

Je ne trouve pas la formule...
Le problème j'ai deux colonnes une avec une liste déroulante avec 4 valeurs (R, S1, S2, S3) et attribué une valeur numérique (1,2,3,4) qui s'affiche dans la case au choix en fonction de la sélection.

Merci de votre aide !

5 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 273
Modifié par Vaucluse le 9/03/2017 à 20:44
Bonsoir
plusieurs options:
1°)formule avec condition, pour un texte en A2, formule en B2:
=SI(A2="R";1;SI(A2="S1";2;SI(A2="S3";3;SI(A2="S4";4;""))))

ou, si vos valeurs sont réellement 1,2,3,4

écrire en Z1: R en Z2 S2; en Z3:S3 en Z4:S4
et la formule est:

=SIERREUR(EQUIV(A2;$Z$1:$Z$4;0);"")

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
5