Somme.si avec critère inférieur ou égal mois [Fermé]

Signaler
-
Messages postés
25768
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 janvier 2021
-
Bonjour,

J’ai du mal avec une somme.si..
Dans mon tableau j’ai les 12 mois de l’année en entête, et dans les lignes d’en dessous des valeurs.
J’aimerais que lorsque je sélectionne un mois dans une cellule (cellule A1 on va dire) ma formule fasse la somme des valeurs correspondantes à ce mois et aux mois antérieurs.
J’ai essayé en faisant
=SOMME.SI(Tableau3[#En-têtes;[janvier]:[decembre]];«<=»&A1;Tableau3[@[janvier]:[decembre]])
Mais les résultats que j’obtiens ne correspondent pas..
Par contre si je met juste A1 comme critère (sans le <= donc) je trouve bien la valeur qui correspond au mois sélectionné.

Je précise que les formats de ma cellule A1 et mes entêtes de mon tableau sont au même format (date mmmm)

J’espère que l’un d’entre vous apportera une solution à mon problème :)

Merci

A voir également:

1 réponse

Messages postés
25768
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 janvier 2021
5 740
Bonjour
comment son entrés vos mois? ce sont des noms ? des N°? des dates?

si ce sont des N°, pour un champ selon l'exemple ci dessous à adapter:

liste de ligne 2 à ligne 100
titre en ligne 1 de B1 àM1

la formule avec un N° de mois entré en Z1:

=SOMMEPROD(($B$1:$M$1<=Z1)*($B$2:$M$100))


si ce sont des dates ( par exemple le 1° jour du mois dans une cellule en format personnalisé type mmmm pour n 'afficher que le nom du mois (c'est ce qu'il y a de mieux à faire)
en entrant le N° du mois en Z1

=SOMMEPROD((MOIS($B$1:$M$1)<=Z1)*($B$2:$M$100))


et si ce sont des textes au clavier:

=SOMME(DECALER($B$2;;;100;EQUIV(Z1;$B$1:$M$1;0)+1))

crdlmnt