Formule Excel si cellule contient un texte...

Résolu/Fermé
JuJu63000
Messages postés
4
Date d'inscription
mardi 28 novembre 2017
Statut
Membre
Dernière intervention
28 novembre 2017
- 28 nov. 2017 à 10:32
 NancyP - 30 sept. 2018 à 20:14
Bonjour,

Voila mon problème:

dans un tableau excel j'ai une colonne B qui contient une liste déroulante de choix (la liste et dans une autre feuille, c'est le choix du type de luminaire, par exemple: Spots encastrés), dans la cellule C je veux mettre la traduction de la cellule B ( par exemple: Recessed spots, qui est situé dans dans une autre feuille).

En gros, il faut que si la colonne B = X (X étant le type de luminaire) alors dans la colonne C j'ai la valeur Y ( Y qui correspond à la colonne de droite de X).






Je vous remercie beaucoup d'avance de votre aide.

4 réponses

Mike-31
Messages postés
17941
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 mai 2022
4 940
28 nov. 2017 à 10:38
Bonjour,
un exemple de ton fichier Excel serait mieux que long discours et capture écran
anonymise ton fichier ou crée un exemple et joint le à la discussion
1) Clic sur ce https://www.cjoint.com/
2) Clic sur Parcourir pour sélectionner ton fichier
3) Clic sur le bouton Créer le lien
4) Un lien en bleu souligné sera généré en haut de page, sélectionne clic droit "Copier"
5) reste plus qu'a le "Coller" dans une réponse avec quelques explications.
0
JuJu63000
Messages postés
4
Date d'inscription
mardi 28 novembre 2017
Statut
Membre
Dernière intervention
28 novembre 2017

28 nov. 2017 à 10:43
Merci pour ton aide, je ne trouver pas comment le faire :)

Voici le lien de l'exemple:

https://www.cjoint.com/c/GKCjOq1aH16

Si tu à des questions en particulière dis le moi, je pense avoir tout dis dans mon explication.
0
Mike-31
Messages postés
17941
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 mai 2022
4 940
28 nov. 2017 à 10:54
Re,

en cellule C5 colle cette formule
=RECHERCHEV(B4;'traductions tableau pdt'!$B$2:$C$27;2;0)

maintenant tu peux l’améliorer, onglet "traductions tableau pdt" ton tableau tu peux le nommer exemple la plage B2:C27 tu la nommes Tablo
la formule devient
=RECHERCHEV(B4;Tablo;2;0)

si tu ne sais pas comment nommer ta plage reviens sur la discussion
0
JuJu63000
Messages postés
4
Date d'inscription
mardi 28 novembre 2017
Statut
Membre
Dernière intervention
28 novembre 2017

28 nov. 2017 à 11:20
Merci, ça marche super bien ! et l'idée de la plage est pas mal pour éviter les formules à rallonge :)

J'aurai une autre question pour améliorer la formule, je voudrais qu'on ne puisse pas fais d'erreur, la si on copie et colle la formule que tu m'a donné( =RECHERCHEV(B4;Tablo;2;0) ) en C5 par exemple cela décale tout, il faudrait remplacer le "B4" par exemple par la colonne B je pense. dis moi si c'est possible ? et encore merci !
0
Mike-31
Messages postés
17941
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 mai 2022
4 940
28 nov. 2017 à 12:21
Re,

B4 par la colonne B non, mais tu peux incrémenter la formule sur la hauteur que tu veux, de B4 tu la tire vers le bas
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 253
28 nov. 2017 à 12:41
Bonjour
(et salut Mike)
et pour copier la formule en C5 en conservant le, B
écrivez d'abord:
=RECHERCHEV($BA;Tablo;0)
qui conservera le B et passera le 4 en 5
le $ devant la colonne bloque la colonne, devant la ligne bloque la ligne et devant tout bloque tout
crdlmnt
0
JuJu63000
Messages postés
4
Date d'inscription
mardi 28 novembre 2017
Statut
Membre
Dernière intervention
28 novembre 2017
> Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022

28 nov. 2017 à 13:56
Merci c'est exactement ce que je voulais !
0
Merci infiniment Mike-31, ça fonctionne :)
0