Formule "si" cellule contient tel ou tel texte [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
jeudi 27 juillet 2017
Statut
Membre
Dernière intervention
19 septembre 2017
-
 Dilou-31 -
Bonjour à toutes et tous,

Je galère depuis plusieurs jours et n'ai trouvé aucune réponse sur les forums.

Voilà le problème:
J'ai en colonne A du texte (par exemple NOM PRENOM)
Je voudrais en colonne B mettre une formule qui me donne un résultat en fonction d'une partie du texte de A.
Exemple: si A1 contient "Fabien" ou "Franck" ou encore d'autres prénoms (environ 10 possibilités), alors ça me renvoie "élève", autrement, rien.

Suis-je assez clair pour que quelqu'un puisse m'aider ?

Merci d'avance pour vos tuyaux





2 réponses

Messages postés
17242
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 octobre 2020
4 283
Bonsoir,

Une formule parmi d'autres

=SI(OU(NB.SI(A2;"*franck*");NB.SI(A2;"*michel*");NB.SI(A2;"*fabien*"));"élève";"") 


à toi d'ajouter des NB.SI(A2;"*franck*") sans oublier les étoiles
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
28
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
4
Date d'inscription
jeudi 27 juillet 2017
Statut
Membre
Dernière intervention
19 septembre 2017

Merci Mike !
Je viens de tester, et visiblement ça fonctionne.
Je termine ma formule avec tout ce dont j'ai besoin et reviens vers vous si je retombe en panne !

Encore merci
Messages postés
17242
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 octobre 2020
4 283 >
Messages postés
4
Date d'inscription
jeudi 27 juillet 2017
Statut
Membre
Dernière intervention
19 septembre 2017

Re,

Ok pas de problème, de toute façon si ton problème est résolu n'oublie pas de mettre le statut de la discussion en résolu.
Cordialement
Bonjour,

J'ai besoin d'obtenir une formule:

Si dans ma colonne A réponse "NON" donner en colonne C la valeur écrite d'une cellule en colonne B.

Merci à tous
Bonjour,
J'avais un cas similaire. Cela marche parfaitement. Merci beaucoup!
Cordialement
Messages postés
2793
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
10 octobre 2020
381
Bonjour,

Quelle est la forme exacte de ton texte ? valable pour toute la colonne nom/prenom ?
Et tu ne peux pas dissocier le nom du prénom en 2 colonnes ??

Bonjour ,

Joins un fichier-test, (avec TOUTES les explications et les résultats souhaités) ou mieux, si c'est possible, le fichier concerné, c'est plus commode pour les intervenants.

1) Tu vas dans https://www.cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes s'affiche le lien en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans la discussion, et, dans ton message de réponse, tu fais : "Coller".

Cordialement.