Problème de connexion à la base de données MySql sur server Wamp

Résolu/Fermé
Adriano87
Messages postés
15
Date d'inscription
jeudi 22 septembre 2016
Statut
Membre
Dernière intervention
25 avril 2017
- 20 mars 2017 à 10:56
Adriano87
Messages postés
15
Date d'inscription
jeudi 22 septembre 2016
Statut
Membre
Dernière intervention
25 avril 2017
- 20 mars 2017 à 18:21
Bonjour,

mon application c# codée avec VS 2012 (avec MySql.Data.dll) doit se connecter à une bdd MySql sur Wamp 3.0.6 mais j'obtiens systématiquement cette erreur :

"Authentication to host '127.0.0.1' for user 'root' using method 'mysql_native_password' failed with message: Access denied for user 'root'@'localhost' (using password: NO)"

J'ai eu beau essayer avec différents utilisateurs qui ont les privilèges, les deux type de mot de passe, et je peux me connecter par l'interface phpMyAdmin, mais avec l'appli en c# ça ne passe pas.

Je pense que le problème vient de l'autentification, car vu le message la connexion au serveur semble Ok.

J'ai cherché sur le net, j'ai visionné des tutos qui m'ont fait modifier plusieurs fichiers de conf apache en mettant "Allow from all", mais ça n'a rien changé.

Voici le code en résumé :


MySqlConnection theSqlConnection = null;

string serveurName = "127.0.0.1";
string dataBase = "maBase";
string userId = "root";
string userPassword = "";

string connectionstring = "SERVER=" + serverName + ";DATABASE=" + dataBase + ";UID=" + userId + ";PASSWORD=" + userPassword;

theSqlConnection = new MySqlConnection(connectionstring);

theSqlConnection.Open();


Pourriez vous m'aider s'il vous plait?
A voir également:

5 réponses

Adriano87
Messages postés
15
Date d'inscription
jeudi 22 septembre 2016
Statut
Membre
Dernière intervention
25 avril 2017
1
20 mars 2017 à 13:32
Bonjour jordane et merci de bien vouloir m'aider.

Alors root est localhost mais les autres users que j'ai testé ont % pour certains, donc à priori ça ne vient pas de là.

Pour ce que tu me recommande de faire ensuite, peux tu être plus précis s'il te plait, comment dois je modifier précisément my.ini ?
;skip-networking

; Disable Federated by default
skip-federated


et bind-address?


par ailleurs, si ça peut aider à résoudre le problème :
je dois aussi me connecter à cette même base de données par l'intermédiaire d'un site web php et voici ce que j'obtiens avec chrome :

( ! ) Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[HY000] [1045] Access denied for user 'root'@'localhost' (using password: NO)' in C:\wamp64\www\...etc on line 30
( ! ) PDOException: SQLSTATE[HY000] [1045] Access denied for user 'root'@'localhost' (using password: NO) in C:\wamp64\www\...etc on line 30
1
jordane45
Messages postés
35765
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
30 juin 2022
4 200
20 mars 2017 à 14:09
par ailleurs, si ça peut aider à résoudre le problème :
je dois aussi me connecter à cette même base de données par l'intermédiaire d'un site web php

Le site web se trouve sur le même serveur ?
As tu essayé avec autre chose que ROOT ?
Quel est le code de connexion que tu as utilisé ?
Le user (autre que root) que tu as/vas essayer ... a-til les droits sur le base ?
0