Date infinie

[Résolu/Fermé]
Signaler
Messages postés
54
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
3 juillet 2017
-
Messages postés
26189
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2021
-
Bonjour

J'ai créé un fichier de suivi de formation sur EXCEL. Chaque formation a une durée de validité. en fonction de la date à laquelle la formation a été faîte, j'ai donc une date de renouvellement qui se calcule.
L'une de ses formations est valable toute la vie. Comment faire pour le faire apparaître dans ma colonne date de renouvellement ?

Merci d'avance

Emilight

1 réponse

Messages postés
26189
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2021
6 056
Bonjour
On va être obligés d'imaginer avec ce que vous nous dites
alors on suppose que vous avez, disons
une colonne B date de formation,
une colonne C durée de validité dans laquelle vous placez une info du genre de la durée de validité en mois pour l'exemple ou le terme "validité permanente" ou tout autre

Et donc pour avoir une date de renouvellement en D vous pouvez écrire:(si la valeur C est en mois)

=SI(C2="Validité permanente";C2;MOIS.DECALER(B2;C2))

crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
54
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
3 juillet 2017
1
La durée de validité est en année. Existe-t-il la même formule pour les années ?
Messages postés
54
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
3 juillet 2017
1
J'ai réussi à adapter mon calcul avec votre formule mais le problème c'est que j'aimerais que ce soit une date qui s'affiche, même si elle est très éloignée et qu'on sera tous morts d'ici là!!
Est-ce plus simple de mettre une durée de validité de 100 ans ou c'est possible d'écrire l'infini en date ?
Messages postés
26189
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2021
6 056 >
Messages postés
54
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
3 juillet 2017

Re

si la validité est en année:

soit

=SI(C2="Validité permanente";MOIS.DECALER(B2;21200);MOIS.DECALER(B2;C2*12)

ou encore

=DATE(ANNEE(B2)+SI(C2="Validité permanente");100;C2);MOIS(B2);JOUR(B2))

rendez vous le 3/3/2117 pour contrôle du fonctionnement

mais vous pouvez aussi utiliser, pour rester propre:

=SI(C2="Validité permanente";'"--/--/----";MOIS.DECALER(B2;C2*12))

ou placer ce que vous voulez entre les guillemets

crdlmnt
Messages postés
54
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
3 juillet 2017
1
La dernière formule est la meilleure je pense!!
Merci beaucoup de votre aide
Messages postés
26189
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2021
6 056
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt