Somme.si.ens avec 3 conditions... 2 en colonnes et une en ligne [Résolu/Fermé]

Signaler
Messages postés
30
Date d'inscription
samedi 29 juillet 2017
Statut
Membre
Dernière intervention
17 janvier 2018
-
Messages postés
30
Date d'inscription
samedi 29 juillet 2017
Statut
Membre
Dernière intervention
17 janvier 2018
-
Bonjour,
J'ai un tableau excel comptabilisant mes besoins en pot en fonction des semaines.
Chaque pot est désigné par son diamètre et sa couleur. J'aurais voulu comptabilisé mes besoins totaux pour un Ø de pot en fonction de sa couleur pour une semaine donnée.
J'ai essayé cette formule =SOMME.SI.ENS($D$3:$AC$934;$B$3:$B$934;B936;$C$3:$C$934;C936;$D$2:$AC$2;F936) mais cela ne fonctionne pas. Vous trouverez ci-joint mon tableau ainsi que ma tentative de formule tout en bas de ce même tableau. Si vous pouviez m'aider. Merci.
Cordialement
https://www.cjoint.com/c/HApoO7MFuJU

3 réponses

Messages postés
2154
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
21 octobre 2020
863
Bonsoir
une piste
Messages postés
8212
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
22 octobre 2020
1 498
Bonjour,

Tu peux insérer une ligne de titre en 936 pour les critères et utiliser BDSOMME() :
=BDSOMME($A$2:$AB$934;C937;A936:B937)


Messages postés
8212
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
22 octobre 2020
1 498
Les formules de base de données (BD....) sont spécialement prévues pour ce genre de problème (simple et efficace).
Messages postés
30
Date d'inscription
samedi 29 juillet 2017
Statut
Membre
Dernière intervention
17 janvier 2018

merci beaucoup
cordialement
Messages postés
12789
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 octobre 2020
2 048
Bonjour

Ta formule ne correspond à rien , tu ne devrais avoir que des plages d'une colonne et puis tu fais référence à la cellule F936 qui est vide !
Il faut pour la plage somme partir de référence de la 1ere colonne (S01) et décaler cette référence du nombre de colonne correspondant à la place de la semaine recherchée dans les différentes colonnes du tableau, d'où ta formule rectifiée :
=SOMME.SI.ENS(DECALER($C$3:$C$934;;EQUIV(C936;C2:AB2;0)-1);$A$3:$A$934;A936;$B$3:$B$934;B936)

Cdlmnt
Via

Messages postés
30
Date d'inscription
samedi 29 juillet 2017
Statut
Membre
Dernière intervention
17 janvier 2018

Bonsoir
merci beaucoup je ne connaissais pas la fonction décaler
Cordialement