Rechercher texte dans colonne puis afficher une cellule [Résolu/Fermé]

Signaler
-
 frmi -
Bonjour,

Je fais une recherche d'un texte contenu dans la cellule D49 sur une colonne d'une autre page.

Si le texte est trouvé alors cela affiche "oui" dans le cas contraire cela affiche "non".

Voici la formule : =SI(EQUIV(D49;'Infos ID'!$A$1:$A$1000;0);"oui";"non")

Lorsque la formule trouve le mot recherché, j'aimerais qu'elle affiche à la place de "oui" le contenu d'une cellule présente sur la même ligne que la ligne où ce trouve le mot recherché.

Exemple : La cellule A200 contient le mot de la cellule D49 alors affiche le contenu de la cellule B200 à la place de "oui".

Est-ce possible car là je sèche sur le problème.

Merci de votre aide.
Cdl.

3 réponses

Messages postés
16195
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
31 août 2020
3 019
Bonjour

Si la valeur inscrite en D49 (ou D100 ou...) n'est pas dans 'Infos ID' A1:A1000
ta formule renverra #NA plutôt que "non" (erreur dans Equiv)

donc
=SI(NB.SI(plage;D49)>0;DECALER('Infos ID'!A$1;EQUIV(D49;plage;0)-1;1);"non")
A1:A1000 nommé "plage"


la maquette
https://mon-partage.fr/f/D1xvGUmH/


1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61369 internautes nous ont dit merci ce mois-ci

Messages postés
112
Date d'inscription
mercredi 27 juillet 2016
Statut
Membre
Dernière intervention
2 juin 2020
1
Bonjour,
à la place de ton "oui" dans ta formule, mets une recherchev
=SI(EQUIV(D49;'Infos ID'!$A$1:$A$1000;0);recherchev(D49;$A$200:$B$200;2;faux);"non")
Merci pour vos réponses rapides, j'ai résolu mon soucis grâce aux idées que vous avez émises.

Au final, voici ma formule :

=SI(NB.SI('Infos ID'!A$10:A$1000;D2)>0;DECALER('Infos ID'!A$10;EQUIV(D2;'Infos ID'!A$10:A$1000;0)-1;9);"non")

J'affiche ainsi la 9e cellule de la ligne où le critère de recherche a été trouvé.

Cdl.