Chercher une valeur dans une plage de cellule

Fermé
Fr68Ch - 5 août 2010 à 12:52
Patrice33740
Messages postés
8549
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
7 mai 2022
- 16 sept. 2019 à 22:54
Bonjour,

J'aimerais utiliser une fonction qui permet de chercher une valeur dans une plage de cellule excel

Par exemple dans la plage B1:B10, je recherche la valeur (qui ne peut être qu'unique) ; si je trouve cette valeur, la valeur à reporter dans la cellule est 1

Voila

Merci d'avance

4 réponses

Patrice33740
Messages postés
8549
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
7 mai 2022
1 750
Modifié par Patrice33740 le 10/08/2010 à 11:12
En supposant que la valeur a chercher soit entrée en A1, que la plage où chercher soit de B1 à B10 dans la cellule où tu veux le résultat tapes :

=SI(ESTNA(EQUIV(A1;$B$1:$B$10;0));"";1)


Nicolas dit toujours : « C'est facile quand on connait la réponse ! »
13
Un grand merci ! J'avais l'an passé trouvé une formule à partir de RECHERCHE mais impossible de la retrouver, alors par chance je suis arrivé ici et cela m'a dépanné.
BM
0
Un grand merci aussi, j'ai ENFIN pu résoudre un problème de ce genre grâce à votre formule.
Je cherchais la valeur d'une cellule (une cellule après l'autre) dans une liste de cellule afin d'afficher Vrai/Faux. C'est fait et réussi. Je vous met la formule si cela peut aider.
=SI(ESTNA(EQUIV(C4;F:F;0));"Absent";"Présent")
- Donc chercher C4 dans toute les valeurs de la colonne F (quelque soit le nombre de cellule dans la colonne F)
- J'ai copier coller cette formule dans les lignes que je souhaitais vérifier.
PS, correction > J'ai mis le pseudo de Patrice afin de ne pas me créer de compte moi-même!
0
Patrice33740
Messages postés
8549
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
7 mai 2022
1 750 > Patrice33740
16 sept. 2019 à 22:54
Il est préférable de limiter la plage de recherche par exemple:
=SI(ESTNA(EQUIV($C4;$F$1:$F$9999;0));FAUX;VRAI)
0