Formules SI EST VIDE, SINON sous tableur excel [Résolu/Fermé]

Signaler
Messages postés
39
Date d'inscription
dimanche 31 juillet 2016
Statut
Membre
Dernière intervention
11 juin 2017
-
 Utilisateur anonyme -
Bonjour,

Ma question est simple, je souhaite sous excel réaliser la formule suivante, mais je me heurte à quelques problèmes:

SI la case C2 est vide, alors rien. Sinon, si C2>0 alors chiffre "1", Si C2 égal à 0 ou négatif, alors 0...

J'ai beau essayer, j'y arrive pas.

En gros je veux dans ma colonne soit rien (si rien de renseigné en C2), soit des "1" si C2 est positif, soit des 0 si C2 n'est pas positif

Un expert d'excel pour m'aider?

5 réponses

Messages postés
28772
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
18 mai 2020
6 299
Salut,

essayer :
=SI(ESTVIDE(C2);"";SI(C2>0;1;0)) 


cdlt
Utilisateur anonyme
 
Bonjour jee pee,

Ta formule est bonne, et je t'en propose une amélioration :
=SI(ESTVIDE(C2);"";--(C2>0))

Cordialement.  :)
 
Messages postés
25091
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
5 254
Bonsoir
bizarre votre question, alors qu'il suffit pour y répondre d'écrire:

=SI(C2>0;1;"")

êts vous sur de vos explications?

crdlmnt

Messages postés
39
Date d'inscription
dimanche 31 juillet 2016
Statut
Membre
Dernière intervention
11 juin 2017

Nickel, rapide, précis, un grand merci à toi!

j'avais à peu près ça, mais j'me trompais dans les parenthèses je pense...

Encore merci!
Messages postés
39
Date d'inscription
dimanche 31 juillet 2016
Statut
Membre
Dernière intervention
11 juin 2017

Du coup vu que tu m'as l'air câlé j'en profite pour une 2eme question.

Je tiens un tableur sur mes gains poker.

Je voudrais une colonne avec mon % de tables gagnés (d'où les 1 et les 0 de la première question)

J'ai donc maintenant ma colonne en binaire (des 1 quand j'ai gagné, des 0 quand j'ai perdu)

Je voudrais une autre colonne avec le % de tables gagnées...Une idée?
Messages postés
28772
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
18 mai 2020
6 299
Si tes parties sont entre C2 et C5 (4 lignes) :
=(NB.SI(C2:C5;1) / (NB.SI(C2:C5;1)+NB.SI(C2:C5;0))) *100
Messages postés
39
Date d'inscription
dimanche 31 juillet 2016
Statut
Membre
Dernière intervention
11 juin 2017
>
Messages postés
28772
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
18 mai 2020

mmmmh, ça ne fonctionne pas...
J'ai maintenant grâce à ta formule donnée précédemment une colonne Y avec des 1 et des 0....cela va de Y2 à Y1000...j'ai essayé de partir de ta formule ci-haut et remplaçant les C2 par Y2 et C5 par Y1000, mais ça ne fonctionne pas.
Messages postés
28772
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
18 mai 2020
6 299 >
Messages postés
39
Date d'inscription
dimanche 31 juillet 2016
Statut
Membre
Dernière intervention
11 juin 2017

Je viens de faire un test cela fonctionne ???
Messages postés
39
Date d'inscription
dimanche 31 juillet 2016
Statut
Membre
Dernière intervention
11 juin 2017
>
Messages postés
28772
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
18 mai 2020

je m'en suis sorti autrement, en décomposant en étapes...merci à toi en tout cas
Messages postés
39
Date d'inscription
dimanche 31 juillet 2016
Statut
Membre
Dernière intervention
11 juin 2017

@Vaucluse: non, avec votre formule j'ai soit des 1 soit rien....moi je veux soit de 1 soit des 0 soit rien....La formule de jee pee fonctionne parfaitement