Excel ne rien afficher ci case vide

Résolu/Fermé
jlfa
Messages postés
186
Date d'inscription
dimanche 13 septembre 2009
Statut
Membre
Dernière intervention
7 août 2020
- Modifié par jlfa le 16/09/2012 à 12:59
 nance - 10 janv. 2014 à 14:52
Bonjour,

voila mon petit problème je rentre cette formule sur excel =((BZ390*0,95)*0,011)-42
cela marche mais j'ai toujours un résulta de -42 qui s'affiche alors que je voudrais qu'il n'y est rien ci la case al390 n'est pas remplis, j'ai essayer ce genre de formule SI(AL390<>"";ARRONDI(BZ390*0,95;2)*0,011;"")
jusque la çà marche mais je ne parviens pas a ajouter le -42 sans que cela face des erreur Merci pour vos réponses


A voir également:

6 réponses

PapyLuc51
Messages postés
3719
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
18 août 2022
1 144
Modifié par PapyLuc51 le 16/09/2012 à 14:28
=SI(
ESTVIDE(AL390)test logique de ta condition si

;"";valeur_si_vrai ta cellule reste vide si AL390 est vide

(ARRONDI(BZ390*0,95;2)*0,011)-42)valeur_si_faux ce qui veux dire que si AL390 contient un chiffre ou nombre c'est ce calcul qui se fait
9
PapyLuc51
Messages postés
3719
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
18 août 2022
1 144
19 sept. 2012 à 06:33
Bonjour jlfa

Je viens de tester ta formule, et je dois dire qu'on en apprend tous les jours ; elle est bonne mais il y manquait un petit quelque chose pour qu'elle fonctionne selon tes critrères

=SI(AL390<>"";(ARRONDI(BZ390*0,95;2)*0,011)-42;"")

Cordialement
0