Excel ne rien afficher ci case vide [Résolu/Fermé]

Signaler
Messages postés
184
Date d'inscription
dimanche 13 septembre 2009
Statut
Membre
Dernière intervention
22 mai 2020
-
 nance -
Bonjour,

voila mon petit problème je rentre cette formule sur excel =((BZ390*0,95)*0,011)-42
cela marche mais j'ai toujours un résulta de -42 qui s'affiche alors que je voudrais qu'il n'y est rien ci la case al390 n'est pas remplis, j'ai essayer ce genre de formule SI(AL390<>"";ARRONDI(BZ390*0,95;2)*0,011;"")
jusque la çà marche mais je ne parviens pas a ajouter le -42 sans que cela face des erreur Merci pour vos réponses


6 réponses

Messages postés
2668
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
8 juillet 2020
678
=SI(
ESTVIDE(AL390)test logique de ta condition si

;"";valeur_si_vrai ta cellule reste vide si AL390 est vide

(ARRONDI(BZ390*0,95;2)*0,011)-42)valeur_si_faux ce qui veux dire que si AL390 contient un chiffre ou nombre c'est ce calcul qui se fait
9
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61956 internautes nous ont dit merci ce mois-ci

Messages postés
2668
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
8 juillet 2020
678
Bonjour jlfa

Je viens de tester ta formule, et je dois dire qu'on en apprend tous les jours ; elle est bonne mais il y manquait un petit quelque chose pour qu'elle fonctionne selon tes critrères

=SI(AL390<>"";(ARRONDI(BZ390*0,95;2)*0,011)-42;"")

Cordialement
Messages postés
184
Date d'inscription
dimanche 13 septembre 2009
Statut
Membre
Dernière intervention
22 mai 2020
3
Merci ça marche, svp serré t'il possible de m'expliquer cette formule car j aime bien comprendre

Encore merci
Messages postés
2668
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
8 juillet 2020
678
Bonjour

Je te propose cette formule

=SI(ESTVIDE(AL390);"";(ARRONDI(BZ390*0,95;2)*0,011)-42)

Cordialement
Messages postés
184
Date d'inscription
dimanche 13 septembre 2009
Statut
Membre
Dernière intervention
22 mai 2020
3
encore merci
Messages postés
2668
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
8 juillet 2020
678
passe ton sujet en résolu en haut de ton premier message

Cordialement
Merci ça vient grandement de m'aider ! :)