Afficher une valeur en fonction d'une fourchette

Résolu/Fermé
whoisbuch
Messages postés
6
Date d'inscription
mercredi 6 janvier 2010
Statut
Membre
Dernière intervention
7 octobre 2016
- 7 oct. 2016 à 14:23
whoisbuch
Messages postés
6
Date d'inscription
mercredi 6 janvier 2010
Statut
Membre
Dernière intervention
7 octobre 2016
- 7 oct. 2016 à 19:05
Hello,
Je vous contacte car je sèche sur un problème d'excel.

En gros, j'ai une colonne de chiffre compris entre 0 et 50.
A côté, dans une colonne, j'aimerais afficher automatiquement un chiffre compris en 0 et 10 qui fonctionnerait selon une fourche :

Exemple :
- affiche 0 si le nombre est plus petit que 6
- affiche 7,5 si le nombre est compris entre 25 et 28
- affiche 9 si le nombre est compris entre 40 et 47
- ...

Comment pourrais-je faire cela ?

Un tout grand merci à vous

3 réponses

PHILOU10120
Messages postés
6066
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
27 juin 2022
722
7 oct. 2016 à 15:10
Bonjour

Essayer ceci la valeur est en A1 pour cet exemple

=SI(A1<6;0;SI(ET(A1>=25;A1<=28);7,5;SI(ET(A1>=40;A1<=47);9;"")))
1
whoisbuch
Messages postés
6
Date d'inscription
mercredi 6 janvier 2010
Statut
Membre
Dernière intervention
7 octobre 2016

7 oct. 2016 à 15:59
Super, et je peux effectuer plusieurs tris fourchettes imbriqués dans ceci ?
0
PHILOU10120
Messages postés
6066
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
27 juin 2022
722 > whoisbuch
Messages postés
6
Date d'inscription
mercredi 6 janvier 2010
Statut
Membre
Dernière intervention
7 octobre 2016

7 oct. 2016 à 16:08
Bonjour whoisbich

Dans ce cas vous pouvez mettre une référence à la place d'une valeur cela sera plus facile pour faire évoluer

=SI(A1<c1;0;SI(ET(A1>=c2;A1<=c3);7,5;SI(ET(A1>=c4;A1<=c5);9;"")))
et on peut mettre des listes déroulantes sur ces cellules pour pouvoir régler vos fourchettes
0
whoisbuch
Messages postés
6
Date d'inscription
mercredi 6 janvier 2010
Statut
Membre
Dernière intervention
7 octobre 2016
> PHILOU10120
Messages postés
6066
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
27 juin 2022

7 oct. 2016 à 18:02
Oui mais si j'ai 21 fourches ... ça ne sera pas de trop pour les attributs à la fonction SI ?
0
PHILOU10120
Messages postés
6066
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
27 juin 2022
722
7 oct. 2016 à 18:08
BONJOUR

Pouvez vous mettre le fichier sur cjoint.com
Avec une table il serait peut être plus simple de trouver les fourchettes de valeurs

0
Calculez et Comptez des Choses Avec Countcalculate. http://www.fr.countcalculate.com/
0
whoisbuch
Messages postés
6
Date d'inscription
mercredi 6 janvier 2010
Statut
Membre
Dernière intervention
7 octobre 2016

Modifié par whoisbuch le 7/10/2016 à 18:36
Voici avec les fourches dans le fichier ;)

https://www.cjoint.com/c/FJhqCphaCm7

Et un tout grand merci de vous pencher sur mon problème !
0
PHILOU10120
Messages postés
6066
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
27 juin 2022
722
7 oct. 2016 à 18:43
Bonjour Whoisbuch

Votre fichier

http://www.cjoint.com/c/FJhqPEUDSTx
0
whoisbuch
Messages postés
6
Date d'inscription
mercredi 6 janvier 2010
Statut
Membre
Dernière intervention
7 octobre 2016

7 oct. 2016 à 19:05
Génial super !!! Merci beaucoup pour ce travail !
0