Rechercher dans une autre feuille [Résolu/Fermé]

Signaler
Messages postés
611
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
17 janvier 2020
-
Messages postés
17242
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 octobre 2020
-
Bonjour mes amis,
voila la formule que je utilise pour chercher valeur dans une autre feuille:

=+RECHERCHEV(A1;Feuil2!$A:$D;4;0)
exemple: si je cherche : la valeur de A1= Avril dans la feuille 2 et il le trouve ex dans A1 la formule va me donner la valeur qui lui correspond dans le D1,

le problème que j'ai, si si la valeur rechercher n'a pas trouvé, je recois un MSG de type : #N/A

je veux une méthode meme la valeur introuvable je recois 0 ou lieu de #N/A

Merci infiniment mes chèrs amis


1 réponse

Messages postés
17242
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 octobre 2020
4 284
Bonjour,

tout dépend de ta version d'Excel, depuis 2007 tu deux utiliser cette formule
=sierreur(RECHERCHEV(A1;Feuil2!$A:$D;4;0);"")
ou
=sierreur(RECHERCHEV(A1;Feuil2!$A:$D;4;0);0)
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci