Savoir si les valeurs sont présentes dans un autre tableau excel [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
vendredi 18 décembre 2015
Statut
Membre
Dernière intervention
21 décembre 2015
-
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
-
Bonjour,

1- j'ai dans un fichier excel avec 4 colonnes (en feuille 1) comme ci dessous :

A B C D
1 image 1 image 2 image 3 image 4
2 736G.jpg 736G_1.jpg 736G_2.jpg 736G_3.jpg
3 AR283R.jpg AR283R_1.jpg AR283R_2.jpg AR283R_3.jpg
4 AR283W.jpg AR283W_1.jpg AR283W_2.jpg AR283W_3.jpg
5 ..... .... .... ....

2- en feuille 2 j'ai une colonne avec une multitude de données comme ci dessous :

A
1 736G.jpg
2 736G_01.jpg
3 736G_02.jpg
4 736G_03.jpg
5 AR283R.jpg
6 AR283R_1.jpg
7 AR283W.jpg
8 AR283V.jpg
.. ..

par exemple
pour la ref 736G j'ai bien les 3 extensions présentes (AR283R_1.jpg, AR283R_2.jpg, AR283R_3.jpg)sur la feuille 2
mais pour la ref AR283R j'en ai que 1 (AR283R_1.jpg)

ma question est la suivante:
comment faire pour savoir si les valeurs de la feuille 1 sont présente dans la feuille 2
A voir également:

1 réponse

Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 738
Bonjour
une solution par mise en forme conditionnelle

feuil2 donner un nom au champ qui contient vos références (nommer est obligatoire pour une MFC de feuille à feuille)

appelons cette liste REF pour l'exemple
(pour nommer, sélectionnez le champ et inscrivez REF dans la case à gauche de la barre de formule et touche enter)

revenez en feuille 1 sélectionnez la plage A B C D à partir de ligne 3 en supposant que votre plage commence en A3

ruban / accueil / Mise en forme conditionnelle et "nouvelle règle"
dans la fenêtre qui s'affiche: "utiliser une formule pour>..."
entrez la formule suivante:

=NB.SI(REF;A3)>0
cliquez sur Format / formatez le remplissage et OK

vous revenez à la fenêtre de MFC et vous pouvez aussi compléter avec une mis en forme supplémentaire en cliquant sur "nouvelle régle", par exemple, avec cette formule:

=NB.SI(REF;GAUCHE(A3;5)&"*")>0
et un autre format

dans cet ordre, le format 1° sera appliqué aux désignations exactes identiques, le format deux à celle qui ont la même racine de 5 chiffres au début

Dans les deux formules, la cellule indiquée doit être la 1° en haut à gauche de la plage sélectionnée, sans signe $ pour s'ajuster à chaque cellule

crdlmnt





Errare humanum est, perseverare diabolicum
Merci pour votre réponse je vous tiens au courant
Messages postés
3
Date d'inscription
vendredi 18 décembre 2015
Statut
Membre
Dernière intervention
21 décembre 2015

Super merci pour votre aide ça marche
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 738
Pas de quoi, je passe le sujet en résolu
bonne route
crdlmnt