Calculer le temps de trajet en incluant des pauses toutes les 2h [Résolu/Fermé]

Signaler
Messages postés
17
Date d'inscription
jeudi 15 mars 2007
Statut
Membre
Dernière intervention
7 juin 2016
-
Messages postés
17
Date d'inscription
jeudi 15 mars 2007
Statut
Membre
Dernière intervention
7 juin 2016
-
Bonjour,

Je cherche à calculer le temps de trajet en fonction de la durée de trajet et en ajoutant 15min de pause toutes les 2h... SAUF quand la personne arrive à destination avant d'avoir conduit moins de 2h15 après le départ ou après la dernière pause.

Donc théoriquement les résultats escomptez sont :
Pour 2h de trajet = 2 h de durée totale
Pour 2h30 de trajet = 2 h 45 de durée totale
Pour 4h de trajet = 4 h 15 de durée totale
Pour 5h45 de trajet = 6 h 15 de durée totale
Pour 6h de trajet = 6 h 30 de durée totale
...

J'ai pas mal chercher avec différentes astuces, mais là je suis bloqué

Voila ou j'en suis :
Colonne A : Durée de trajet hors pauses
Colonne B : Quotient de 2 "=QUOTIENT(A21;2)" - pour savoir combien il y a de tranche de entière de 2 heures...

Et voici ma formule :
=SI(A21<2.25;A21;SI(A21<4.25;A21+(B21-1)*0.25;SI(A21<6.25;A21+(B21-1)*0.25;SI(A21<8.25;A21+(B21-1)*0.25;"trajet trop long"))))

Elle fonctionne de 1 à 2h25 puis , de 4 à 4.25; de 6 à 6.25; au dessus de 8
...
En faite avec cette formule j'enlève tjs 15 min de pause en trop sauf quand je les personne arrivent après moins de 2h15 sans pauses... Et je n'arrive pas à la modifier sans tout casser.

Au tout départ j'étais parti sur 3 colonnes :
Colonne A : Durée de trajet hors pauses
Colonne B : Quotient de 2 "=QUOTIENT(A21;2)" - pour savoir combien il y a de tranche de entière de 2 heures...
Colonne C : A1/2
Avec la formule comme celle ci mais j'étais aussi resté bloqué.
=SI(B9<=1;A9;SI(B9>4;((B9/2)-1)*0.25+B9;B9/2*0.25+B9))


Question un peu longue, désolé, mais c'est par ce que j'ai bcp cherché avant de la pauser...

Merci pour voter aide !

3 réponses

Messages postés
16174
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
6 août 2020
3 000
Bojour

en A2 la durée
en B2 =EQUIV(A2;{0;2;4;6;8;10;12;14};1)
en C2 =SI(A2>B2;A2+0,15*(B2-1);A2)

ici durée inférieure à 16h

nota
durée marquée sur la forme: hh,mm par ex 11,56--> 11h56mn

 Michel
Messages postés
17
Date d'inscription
jeudi 15 mars 2007
Statut
Membre
Dernière intervention
7 juin 2016

Bonjour,

Merci pour l’intérêt porté à ma question.
La solution donne des erreurs pour les multiples de 2 (hors 2).
Et je trouve que c'est difficilement utilisable car pour 4h30, donc 4.3 le résultat est 4.6 donc 5h00...

Merci
Messages postés
2348
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
9 août 2020
862
Bonjour,
Avec des temps en heures et centièmes en A2 (6,25 h = 6h15min):
=A2+0,25*(ENT(A2/2)-(MOD(A2;2)<=0,25)*1)
Nota: la dernière partie de la formule calcule le nombre de pauses.
Messages postés
17
Date d'inscription
jeudi 15 mars 2007
Statut
Membre
Dernière intervention
7 juin 2016

Bonjour tongtong,

Je test actuellement ta méthode et elle semble parfaitement fonctionner.
Merci beaucoup.

Maintenant je vais la décortiquer pour la comprendre.

Merci encore et merci a tous
Messages postés
2348
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
9 août 2020
862 >
Messages postés
17
Date d'inscription
jeudi 15 mars 2007
Statut
Membre
Dernière intervention
7 juin 2016

Petite indication: (MOD(A2;2)<=0,25)*1) fonctionne comme un SI(...)
Si le reste de la division par 2 est <=0,25 on retranche 1; sinon 0.
Messages postés
17
Date d'inscription
jeudi 15 mars 2007
Statut
Membre
Dernière intervention
7 juin 2016

OK. Merci
Messages postés
818
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
28 octobre 2019
57
Bonjour ,

Si je comprends bien ce que tu demandes , tu devrais essayer quelques choses comme ça :

=SI(MOD(A2+B2*0,25;2,25)=0;A2+(B2-1)*0,25;A2+B2*0,25)


Cordialement,
Messages postés
17
Date d'inscription
jeudi 15 mars 2007
Statut
Membre
Dernière intervention
7 juin 2016

Bonjour,

Merci de l'intérêt que tu porte à mon problème.
La formule marche mieux mais pas encore tout à fait.
En effet, pour
2.2 (soit 2h12) ta formule donne 2.45 (soit 2h27) et pas 2.2 car il roule moins de 2h15.
De même entre 2 exclu à 2.26 exclu ou 4 exclu et 4.26 exclu ou 6 exclu et 6.26 exclu...

J'ai du mal trouver la faille car je ne maitrise pas la fonction MOD.

Est-ce que tu imagine la solution.

Merci encore.

LEBERUT
Messages postés
818
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
28 octobre 2019
57
La fonction MOD permet d’obtenir le reste d’une division entière. (C'est ce qu'on appelle le modulo)

le modulo 3 de 7 est 1 , car 7 = 3 * 2 + 1

Il faut me laisser un peu plus de temps pour analyser.
Mais je comprends bien pourquoi excel ne donne pas la bonne solution.
Messages postés
818
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
28 octobre 2019
57
Je soupçonne que ce soit le quotient que tu fais dans la colonne B.
Essaye avec un quotient par 2,25 au lieu de 2
Messages postés
17
Date d'inscription
jeudi 15 mars 2007
Statut
Membre
Dernière intervention
7 juin 2016

Bonjour,

C'est mieux... mais il reste des erreurs pour les heures suivantes : 2.25; 4.25; 4.26; 6.5.

Merci,

EDIT : Tontong a trouver une solution qui fonctionne proche de la tienne.
Merci bcp à toi