NB.SI.ENS à 3 critères, le dernier étant un critère "date sup" [Résolu/Fermé]

Signaler
Messages postés
21
Date d'inscription
mercredi 20 mai 2015
Statut
Membre
Dernière intervention
29 novembre 2017
-
Messages postés
21
Date d'inscription
mercredi 20 mai 2015
Statut
Membre
Dernière intervention
29 novembre 2017
-
Bonjour, voila ma formule qui ne marche pas.
=NB.SI.ENS(BILAN!E3:E6000;"2015";BILAN!H:H;"";BILAN!K3:K6000;">="&1/9)
JE M'EXPLIQUE, je veux chercher :
En colonne E, si 2015 est présent, aller voir
En colonne H, si rien, aller voir
En colonne K, et comptabiliser les dates supérieures ou égales au 1er septembre.
Pour infos, les dates sont sous la forme: 21/3, 11/9, 1/2, 26/12,....
Je ne dois pas être loin de la vérité, mais je bloque.
Merci d'avance pour votre aide.

1 réponse

Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 738
Bonjour

votre formule suppose:

__que les années sont indiquées en valeurs texte, car vous placez 2015 entre guillemets. Si ce n'est pas le cas, enlevez les guillemets

__que les dates sont indiquées en valeur num, pour pouvoir utiliser >= mais dans ce cas il faut aussi placer la date entre les guillemets, soit:

">=1/9"

__et enfin, il faudrait utiliser les mêmes positions de ligne pour les trois conditions, soit

...........;H3:H6000;.........

ça devrait être tout

crdlmnt
Errare humanum est, perseverare diabolicum
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
21
Date d'inscription
mercredi 20 mai 2015
Statut
Membre
Dernière intervention
29 novembre 2017

Merci, pour votre réponse et vos conseils, que j'ai mis immédiatement en application. Mais désormais, la réponse est 0 alors que se devrait être un nombre positif. J'ai oublié de vous dire que la colonne K jour/date( ex: 1/5) est issue de la colonne I par concatenation jour/mois/année (1/5/2015),cela peu peut être avoir une importance.
Désormais ma formule est =NB.SI.ENS(BILAN!E3:E6000;2015;BILAN!H3:H6000;"";BILAN!K3:K6000;">=1/9")
Merci, pour votre aide.
Messages postés
12907
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
18 janvier 2021
2 107 >
Messages postés
21
Date d'inscription
mercredi 20 mai 2015
Statut
Membre
Dernière intervention
29 novembre 2017

Bonsoir

En attendant le retour de Vaucluse, que je salue au passage ;)
Si les dates sont en format Texte (ce que peut laisser supposer la concaténation) ça ne peut pas marcher, comme dit Vaucluse elles doivent être en format numérique
Pour obtenir une date numérique par concatenation il faut utiliser DATEVAl, par ex avec le jour en C2, le mois en D2 et l'année en E2, la date en F2 sera donnée avec la formule =DATEVAL(C2 & "/" & D2 & "/" & E2)
Ensuite si on veut dans la cellule voir afficher 1/9 au lieu de 01/09/2015 il faut mettre la cellule en Format personnalisé et dans Type entrer : j/m
AInsi on a quand même dans la cellule une vraie date qui peut ensuite être utilisée dans une formule ce qui chez toi donnerait .... BILAN!K3:K6000;">=01/09/2015"
En ce cas la partie BILAN!E3:E6000;2015 est sans doute inutile

Si malgré tout tu n'y arrives pas, postes un exemple allégé de ton fichier (quelques dizaine de lignes suffisent) sur cjoint.com, fais créer un lien, copies-le et reviens l'indiquer ici, on regardera ce qui coince

Cdlmnt
Via
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 738
Si votre colonne K est le résultat d'une concaténation, votre formule ne pourra pas fonctionner
Une concaténation donne pour Excel une valeur texte qui ne peut pas être comparée à > ou = ou<
Avez vous une raison pour que cette colonne vienne d'une concaténation et si oui, essayez ce principe:

=(formule de concaténation)*1

et ensuite vous pourrez écrire simplement:
=NB.SI.ENS(BILAN!E3:E6000;2015;BILAN!K3:K6000;">=1/9/2015")

ou placer la date mini en Z1 par exemple et écrire:

=NB.SI.ENS(BILAN!H3:H6000;"";BILAN!K3:K6000;">="&$Z$1)

crdlmnt
Messages postés
21
Date d'inscription
mercredi 20 mai 2015
Statut
Membre
Dernière intervention
29 novembre 2017
>
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021

Merci vivement pour tous ces éléments de réponses et pour le temps que vous consacrez a aider des personnes comme moi. EXCEL est puissant comme logiciel et pleins d'astuces qui me sont étrangères, en effet je débute !
Bonne journée à vous et merci encore.
Messages postés
21
Date d'inscription
mercredi 20 mai 2015
Statut
Membre
Dernière intervention
29 novembre 2017
>
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021

ça y est j'ai réussi, suite à vos infos, j'ai changé mon fusil d'épaule, désormais j'utilise la colonne I ou les dates ne sont pas au format texte.

'=NB.SI.ENS(BILAN!H3:H6000;"";BILAN!I3:I6000;">31/8/2015";BILAN!I3:I6000;"<20/11/2015")

Sans votre aide, je n'y serai jamais arrivé et j'ai bien compris qu'il faut se méfier des dates issues d'une concatenation car se ne sont plus des chiffres mais du texte.
Une nouvelle fois, un grand merci !!!