Excel si ma cellule contient un texte avec 3 conditions [Résolu/Fermé]

Signaler
-
 Ouss -
Bonjour,

Je chercher à faire une formule dans la quelle je cherche si A1 contient un des 3 mots cherchés (par exemple : table, chaise ou commode) alors B1 est égale au mot trouvé. En résumé si A1 contient chaise alors B1 = chaise, si A1 contient table alors B1 = table...

Merci d'avance pour votre aide.

2 réponses

Messages postés
25367
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
5 521
Bonjour
pour trois mots

=SI(NB.SI(A1;"*chaise*");"chaise";SI(NB.SI(A1;"*commode*");"commode";SI(NB.SI(A1;"*table*");"table";"")))

attention aux signes

et si vos textes à trouver sont dans des cellules, par exemple E1,E2,E3

=SI(NB.SI(A1;"*"&$E$1&"*");$E$1;SI(NB.SI(A1;"*"&$E$2&"*");$E$2;SI(NB.SI(A1;"*"&$E$3&"*");$E$3;"")))

crdlmnt

ps vous pouvez même afficher plusieurs motss'il y en a plusieurs dans le texte:

=SI(NB.SI(A1;"*"&$E$1&"*");$E$1;"")&SI(NB.SI(A1;"*"&$E$2&"*");"_"&$E$2;"")&SI(NB.SI(A1;"*"&$E$3&"*");"_"&$E$3";"")))


Errare humanum est, perseverare diabolicum
Merci beaucoup !!!!
C'est parfait.
Merci bcp Vaucluse , ouf quel soulagement , c'était le dernier Forum à avoir consulté avant que j'abondonne , ur geniousss
Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 282
Bonjour,

Précisons :
que contient réellement ta cellule A1
- uniquement les mots recherchés (table ou chaise ou commode)
-les trois mots recherchés plus d'autres mots
- une phrase ou un groupe de mots qui peuvent contenir ou non le ou les mots recherchés.

Dans le deuxième cas on peut utiliser la formule suivante :

=SI(A3="chaise";+A3;SI(A3="table";+A3;SI(A3="commode";+A3;"")))

A+

pépé
Bonjour,
A1 contient toujours un des 3 mots recherchés + d'autres mots (exemple : table basse, petite commode...).
C'est le contient qui me pose problème.
Merci.