Www.monsite.com ne s'affiche pas , index.php [Résolu/Fermé]

Signaler
-
Messages postés
4606
Date d'inscription
lundi 7 novembre 2005
Statut
Contributeur
Dernière intervention
30 avril 2020
-
salut, en local, mon site http://localhost/mon site sous XAMPP marche impeccablement. Je viens de le téléchargé sur mon serveur qui supporte PHP et j'ai le problème suivant:

quand je rentre l'adresse www.monsite.com il s'affiche mal. Quand je rentre

www.monsite.com/index.php , c'est parfait, comme en local. Je me tord les méninges depuis 2 h pour trouver ce qui ne va pas, en vain.

Qui peut m'aider? Pourquoi index.php n'est pas lu automatiquement.
Cela a marché auparavant.

Je suis perdu, aidez-moi svp.
Merci

7 réponses

Messages postés
2480
Date d'inscription
vendredi 29 octobre 2004
Statut
Contributeur
Dernière intervention
13 février 2018
585
Salut,

"quand je rentre l'adresse www.monsite.com il s'affiche mal"

C'est à dire ? Peut le voir ?


As-tu un fichier index.html à la racine du site ?
salut, ok mais c'est un site en allemand pour une avocate, je suis parfait bilingue.

http://www.rechtsanwaltskanzlei-steineck.de/


et http://www.rechtsanwaltskanzlei-steineck.de/index.php

c'est impec.

Avec mon FTP, j'ai vu aucun index.html

Serait-ce le fichier home.php ou home.html qui poserait problème?

j'ai renommé home.php en home2.html et le problème reste.

Je tourne en rond.

Merci pour votre aide
Messages postés
2480
Date d'inscription
vendredi 29 octobre 2004
Statut
Contributeur
Dernière intervention
13 février 2018
585
Il s'agit très probablement d'un problème en PHP.

Peut tu m'envoyer par message privé (question de sécurité) le contenu de index.php

PS : dans les balises code, c'est important pour moi.
bizarre, sur mon serveur ftp, j'ai un repertoire /logs qui contient ceci

répertoire traffic.html qui contient:

01.html
02.html
03.html
04.html
05.html
06.html
07.html
11.html
12.html
index.html


dans log il y aussi des tas de fichiers comme:

access.log
.....
........
ftp-log


que veux-tu dire en privé avec code? J'ai pas tom email.

a+
Messages postés
2480
Date d'inscription
vendredi 29 octobre 2004
Statut
Contributeur
Dernière intervention
13 février 2018
585
Le site à une fonctionne de messagerie privé quand on est inscrit (voir le logo à droite des chaque commentaire).
Messages postés
4606
Date d'inscription
lundi 7 novembre 2005
Statut
Contributeur
Dernière intervention
30 avril 2020
1 263
tu es hébergé chez qui ?

c'est bizarre en fait, a mon avis y'a aucune erreur de php, ca vient du serveur. car dans la page (sans index.php) toute la partie head est passé en commentaire <--! tout le contenu du head, balise body...-->
Messages postés
2480
Date d'inscription
vendredi 29 octobre 2004
Statut
Contributeur
Dernière intervention
13 février 2018
585
Pas tout à fait,le header était entièrement supprimé ainsi que le menu, si tu regarde bien il y a 2 doctype dont 1 en commentaire ... c'est un peu bizarroïde tous ça.
salut, j'ai trouvé une solution radicale: j'ai uploadé toute ma dernière version de sécurité de mon site qui date d'hier, en faisant quelques changements de présentation et cela MARCHE!
(oui, je copie chaque jour les sites sur lesquel sje travaille, c'est une bonne sécurité, par ex. site140707, site 150707,etc...
Cela ne nous apprendra pas cependant ce qui n'a pas fonctionné.
Je préfère me tordre les méninges sur d'autres problèmes de programmation et de script.
Je suis hébergé chez www.web.de

Merci encore
A+
Messages postés
2480
Date d'inscription
vendredi 29 octobre 2004
Statut
Contributeur
Dernière intervention
13 février 2018
585
Chez pas si t'as regardé la source mais dans ta pas je tu as 2 fois :
</html>
</body>
Messages postés
4606
Date d'inscription
lundi 7 novembre 2005
Statut
Contributeur
Dernière intervention
30 avril 2020
1 263
Chez pas si t'as regardé la source mais dans ta pas je tu as 2 fois

--> je sais (a la rigueur ch'ais en poussant un peu loin)
--> page
;-)
Messages postés
2480
Date d'inscription
vendredi 29 octobre 2004
Statut
Contributeur
Dernière intervention
13 février 2018
585
Ro fé chiez ^^
Messages postés
4606
Date d'inscription
lundi 7 novembre 2005
Statut
Contributeur
Dernière intervention
30 avril 2020
1 263
:-D