Savoir si a et b sont apparu au meme moment

Résolu/Fermé
Tuixx Messages postés 21 Date d'inscription mercredi 30 novembre 2011 Statut Membre Dernière intervention 4 novembre 2015 - Modifié par Tuixx le 21/07/2015 à 16:24
Tuixx Messages postés 21 Date d'inscription mercredi 30 novembre 2011 Statut Membre Dernière intervention 4 novembre 2015 - 22 juil. 2015 à 12:12
Bonjour,

J'aimerais savoir de mon tableau Excel, quel est le nombre de Objets (Objet Z,Y,X, ect...) qui comportent les problèmes a et b, survenu au même moment ü ( après une même durée d'utilisation).
Donc a et b surviennent plusieurs fois pour un même objet (des fois plusieurs fois au même moment) mais je cherche juste a savoir si a et b sont survenu au même moment pour un Objet et donc compter le nombre d'objets qui presente ces caractéristiques.

a et b sont fixes (sous forme texte).

j'ai pensé a utiliser la fonction =Si(Et("a"=??;"b"=??);"1";"0") mais vu que le temps n'est pas toujours le meme, je ne sais pas trop comment faire. De plus cette méthode va me compter toutes les fois où a et b apparaissent au même moment, or je veux juste savoir si ça arrive pour chaque objet.

J'espère que vous m'avez compris... Je suis allemand a la base et je m'efforce de travailler mon francais.
Merci mille fois.
Cordialement
Tuixx

4 réponses

pépé35530 Messages postés 2941 Date d'inscription vendredi 1 mai 2009 Statut Membre Dernière intervention 19 mars 2016 1 376
22 juil. 2015 à 10:42
Bonjour,

Ci-joint un fichier Excel

https://www.cjoint.com/c/EGwiONxV08B

A+

pépé
1
Tuixx Messages postés 21 Date d'inscription mercredi 30 novembre 2011 Statut Membre Dernière intervention 4 novembre 2015
22 juil. 2015 à 11:17
Merci enormenent Pepe pour ton aide!!

je viens de tester la formule et c'est presque ce que je recherche! Le seul Problème c'est que j'obtiens "ident" pour des pannes de type k ou l, et je recherche uniquement les pannes a et b. (a=0x7845DE TEXT, b=0x22598F3 TEXT).

J'ai commencé à faire l'analyse a la main parce que je viens d'apprendre que j'ai ma deadline demain matin. Mes collègues ne sont pas très compréhensifs de mon niveau d'Excel ahaha...
0
pépé35530 Messages postés 2941 Date d'inscription vendredi 1 mai 2009 Statut Membre Dernière intervention 19 mars 2016 1 376 > Tuixx Messages postés 21 Date d'inscription mercredi 30 novembre 2011 Statut Membre Dernière intervention 4 novembre 2015
22 juil. 2015 à 12:00
Bonjour,

pour éliminer les autres problèmes, faire un deuxième tri sur la colonne "Problème" et ne conserver dans le filtre que les événements a et b

A+

pépé
0
Tuixx Messages postés 21 Date d'inscription mercredi 30 novembre 2011 Statut Membre Dernière intervention 4 novembre 2015
22 juil. 2015 à 12:12
Merci! Tout fonctionne.
Je trouve ca stupide qu'on ai pas de cours de excel et Matlab a l'université.
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 318
21 juil. 2015 à 16:27
Bonjour
"J'espère que vous m'avez compris "
Be heu..... pas tout à fait non... et surtout on a du mal à savoir ce qui définit le "moment" qui doit être identique à un autre
si vous avez un modèle disponible avec quelques explications, déposez le sur:
https://www.cjoint.com/
et revenez ici coller le lien donné par le site
A vous lire
0
En fait, chaque objet a été utilisé sur un certains nombre de KM, donc je cherche a savoir si pour l'objet Z par exemple, le problème a ET b sont survenu a x km. (Donc a à x km et b à x km, ou les deux x sont égaux)
0
pépé35530 Messages postés 2941 Date d'inscription vendredi 1 mai 2009 Statut Membre Dernière intervention 19 mars 2016 1 376
21 juil. 2015 à 17:31
Bonjour,

On aimerait souvent que les internautes français aient le même niveau d'orthographe et de rédaction que toi.
Par contre, je n'ai pas très bien compris ton problème, pourrais-tu être plus concret ou fournir un fichier d'exemples.
Mais peut-être ton problème sera-t-il repris par un autre internaute.

A+

pépé
0
Je met tout sur un document Word pour corriger les fautes .... :)
je vous envois ça demain car je n'ai pas le fichier sur mon ordinateur personnel. Et c'est interdit par mon entreprise de transmettre les données donc je vais envoyer un fichier type.
Merci
0
pépé35530 Messages postés 2941 Date d'inscription vendredi 1 mai 2009 Statut Membre Dernière intervention 19 mars 2016 1 376 > Tuixx
21 juil. 2015 à 19:02
Bonjour,

j'ai créé un petit fichier excel. Ce n'est sans doute pas ce que tu demandes mais cela peut faire peut être avancer les choses.

https://www.cjoint.com/c/EGvq7Nn6m2B

Pour être opérationnel, le fichier doit faire l'objet d'un tri croissant sur la première colonne. Il fait alors apparaître un message lorsque sur deux lignes successives on trouve le même objet, le même nombre de kilomètres, mais une panne a et une panne b.

A+

pépé
0
Tuixx Messages postés 21 Date d'inscription mercredi 30 novembre 2011 Statut Membre Dernière intervention 4 novembre 2015
22 juil. 2015 à 08:26
Salut!
Si c'est de ce type la (en plus compliqué). Sauf qu'il y a aussi des pannes c, d ,ect... mais seulement a et b m'intéressent.
J'ai fait un petit fichier (beaucoup) plus simple que mon Excel original

http://www.cjoint.com/c/EGwgruxkFME

Je veux juste savoir si a et b surviennent au même kilométrage sur un objet Z (il y a environ 70 objets a analyser)
Ta formule =WENN(UND(B2<>B3;C2=C3;A2=A3);"deux pannes";"") s'applique seulement si a et b se suivent non?

Cordialement
0
Tuixx Messages postés 21 Date d'inscription mercredi 30 novembre 2011 Statut Membre Dernière intervention 4 novembre 2015
22 juil. 2015 à 09:13
Je viens d'appliquer la formule: =WENN(UND("a"<>"b";AJ28497=AJ28511;F28497=F28511);"1";"0") a mon Excel. J'ai bien un 1 quand deux kilometrages sont pareils mais la condition a ET b n'est pas prise en compte
0
pépé35530 Messages postés 2941 Date d'inscription vendredi 1 mai 2009 Statut Membre Dernière intervention 19 mars 2016 1 376
Modifié par pépé35530 le 21/07/2015 à 18:36
Bonjour,

Si on prend l'exemple de véhicules, tu souhaiterais savoir au bout de combien de kilomètres telle panne est survenue (dans ton problème deux pannes survenant en même temps donc au même nombre de kilomètres).
Le "moment" pourrait s'exprimer en kilomètres, en heures d'utilisation, etc...
Il serait intéressant d'avoir un extrait de ta base de données.
A+

pépé
0