Problemes excel

[Résolu/Fermé]
Signaler
-
Messages postés
26194
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 septembre 2021
-
Bonjour,
j'ai un petit problème concernant excel.
Tout d'abord, j'ai une feuille intitulé planning et après j'ai une feuille par personne cad une feuille intitulé marc, une autre pierre...
Dans chacune de ces feuilles, il y a une colonne pour le n°de société et une autre pour le nom de société. (exemple : 1289 - Madame X)
Je voudrais que dans le planning, des que je mets un numéro il me cherche dans les différentes feuilles le nom correspondant à ce numéro.

Est-ce possible & comment ?

Merci

1 réponse

Messages postés
26194
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 septembre 2021
6 067
Bonjour
le plus simple serait d'établir dans une base de données la liste des N° et des noms.
ensuite si le nom est celui que vous donnez à chaque onglet,, il est facile de retrouver toutes les données

ou alors il, faut que vos feuille individuelles soit nommées avec le numéro plutôt qu'avec le nom, ainsi vous pouvez utiliser dans planning, cet exemple à adapter

l'onglet est nommé du numéro de la personne
le nom sur chaque onglet individuel est inscrit en C2
la formule pour avoir le nom dans planning si vous entrez le N° en A2, en B2:
=INDIRECT("'"&A1&"'!C2")
et ainsi de suite pour les autres infos dont vous pourriez avoir besoin

crdlmnt
le nom des feuilles n'a rien avoir avec les nom de société...
Messages postés
26194
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 septembre 2021
6 067
quelles sociètés? et pourquoi?
vous parlez de nom de personne et maintenant de sociétés?
c'est un planning de quoi que vous faites?
et quel rapport avec ce que je vous propose?
J'ai trois feuilles
1 - planning
2 - Marc
3 - pierre

Dans les feuilles marc et pierre, il y 3 colonnes avec dans la premiere le numéro de la société, dans la deuxieme les noms des sociétés, et dans le troisieme les heures travaillées dans chaque société.

Dans le planning, il y a juste tous les numéros des sociétés.
Je voudrais avoir une formule permettant de mettre directement le nom de société à côté du numéro correspondant.
Messages postés
26194
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 septembre 2021
6 067
alors si vous n'avez que deux feuilles à exploiter.
à adapter
dans la feuille planning, avec le N° en A2, en B2, la formule

=RECHERCHEV(A2;SI(NB.SI(marc!A:A;A2);marc!A:C;pierre!A:C);2;0)

et pour éviter un affichage parasite si A est vide ou le N° n'existe pas, à partir d'Excel 2007:

=SIERREUR(RECHERCHEV(A2;SI(NB.SI(marc!A:A;A2);marc!A:C;pierre!A:C);2;0);"")

crdlmnt