EXCEL SOMME.SI avec condition sur des dates

Résolu/Fermé
Olivier - 2 févr. 2005 à 10:36
 Roro - 18 janv. 2021 à 18:15
Bonjour à tous,

Je ne parviens pas à utiliser la fonction SOMME.SI avec comme plage de condition une colone (disons la A) contenant des dates, une condition basée sur une autre date (disons qu'elle se trouve en cellule C1) et une plage de somme numérique (disons en colone B).

Les syntaxes suivantes ne fonctionnent pas :
=SOMME.SI( A1:A5 ; <=C1 ; B1:B5 )
=SOMME.SI( A1:A5 ; "<=C1" ; B1:B5 )

L'idée est de suivre une trésorerie .... mille merci d'avance pour votre aide qui m'évitera de devenir chévre.
A voir également:

6 réponses

La solution que je préfère est (basée sur un exemple de bornage entre 3 et 7 inclus):
{=SOMME(SI(B53:B62>=3;SI(B53:B62<=7;C53:C62;0)))}




B53:B62 est la liste de référence (la date dans votre cas)
C53:C62 est la liste de données à extraire (les montants de facture dans votre cas)
3 est la date de bornage basse de la période incluse
3 est la date de bornage haute de la période incluse

Sur la base de votre demande :
{=SOMME(SI(Première cellule de la liste de dates:Dernière cellule de la liste de dates)>=3 ;SI(Première cellule de la liste de dates:Dernière cellule de la liste de dates <=7; Première cellule de la liste des montants:Dernière cellule de la liste des montants;0)))}
123
bonjour, je suis d'acord avec toi john mais je ne sais plus comment on fait pour rajouter les acolades { }
merci d'avance
0
Raymond PENTIER
Messages postés
56290
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
28 juin 2022
17 216
15 mars 2012 à 21:43
C'est Excel même qui place les accolades lorsque tu valides une formule matricielle :
Tu saisis =SOMME(SI(B53:B62>=3;SI(B53:B62<=7;C53:C62;0)))
mais au lieu de valider par ENTRÉE seule, tu fais CTRL+MAJ+ENTRÉE
0
C'est une solution sauf qu'elle ne pourra pas marcher si l'inervalle de date est à cheval sur deux mois différents! réfléchissons davantage!
0
Raymond PENTIER
Messages postés
56290
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
28 juin 2022
17 216
10 avril 2012 à 13:55
Qui a inventé ça ? Essaie =B3-B2 et tu trouveras bien 30 (avec 22/09 en B2 et 22/10 en B3).
0
AU top ça marche !
0