EXCEL SOMME.SI avec condition sur des dates [Résolu/Fermé]

Signaler
-
 Pib -
Bonjour à tous,

Je ne parviens pas à utiliser la fonction SOMME.SI avec comme plage de condition une colone (disons la A) contenant des dates, une condition basée sur une autre date (disons qu'elle se trouve en cellule C1) et une plage de somme numérique (disons en colone B).

Les syntaxes suivantes ne fonctionnent pas :
=SOMME.SI( A1:A5 ; <=C1 ; B1:B5 )
=SOMME.SI( A1:A5 ; "<=C1" ; B1:B5 )

L'idée est de suivre une trésorerie .... mille merci d'avance pour votre aide qui m'évitera de devenir chévre.

6 réponses

La solution que je préfère est (basée sur un exemple de bornage entre 3 et 7 inclus):
{=SOMME(SI(B53:B62>=3;SI(B53:B62<=7;C53:C62;0)))}




B53:B62 est la liste de référence (la date dans votre cas)
C53:C62 est la liste de données à extraire (les montants de facture dans votre cas)
3 est la date de bornage basse de la période incluse
3 est la date de bornage haute de la période incluse

Sur la base de votre demande :
{=SOMME(SI(Première cellule de la liste de dates:Dernière cellule de la liste de dates)>=3 ;SI(Première cellule de la liste de dates:Dernière cellule de la liste de dates <=7; Première cellule de la liste des montants:Dernière cellule de la liste des montants;0)))}
121
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

bonjour, je suis d'acord avec toi john mais je ne sais plus comment on fait pour rajouter les acolades { }
merci d'avance
Messages postés
52430
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
14 268
C'est Excel même qui place les accolades lorsque tu valides une formule matricielle :
Tu saisis =SOMME(SI(B53:B62>=3;SI(B53:B62<=7;C53:C62;0)))
mais au lieu de valider par ENTRÉE seule, tu fais CTRL+MAJ+ENTRÉE
C'est une solution sauf qu'elle ne pourra pas marcher si l'inervalle de date est à cheval sur deux mois différents! réfléchissons davantage!
Messages postés
52430
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
14 268
Qui a inventé ça ? Essaie =B3-B2 et tu trouveras bien 30 (avec 22/09 en B2 et 22/10 en B3).
salut olivier,
la fonction si en excel se compose de 3 parties
1- la condition
2- le resultat si lma condition est vérifiée.
3- // // n'est pas vérifier.
Bopnne chance.
Merci
> Olivier
Si tu obtiens une date à la place du résultat sous forme de nombre, change ton format "nombre de la cellule"
> Olivier
Correctif...oups
=Somme.si(a1:a3;"<=" & c1;b1:b6)
> David_wklw
Super, ca marche. Merci 1000 fois.
> David_wklw
David
la formule somme.si (plage;critere; plage) pour entrainer un calcul de montant jusqu'à une date donnée fonctionne, mais par contre quelle est la syntaxe au , si on veut faire une somme de montants sur une plage de date ? exemple je veux faire la somme des montants de factures qui vont du 01/01/08 au 31/01/08, je ne trouve pas la syntaxe du critère à utiliser
merci
11 ans après merci mec!
=SI(A1<AUJOURDHUI();"oui";"non")
Olivier.
Messages postés
224
Date d'inscription
samedi 25 octobre 2003
Statut
Membre
Dernière intervention
3 mai 2007
44
ca marche super merci
Messages postés
52430
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
14 268
En A10 taper la date désirée
En B10 =SOMME.SI(B1:B9;A10)
En C10 =SOMME.SI(C1:C9;A10)
Merci de votre aide :
colonne a = une date, je voudrais en colonne b : si a<date du jour;"oui";"non"
mon problème est : si colonne a < à la date du jour, je ne vois pas comment formuler ça en format xls.