Si en feuille1 cellule C5 est différent de 0 copie le texte de [Fermé]

Signaler
Messages postés
12
Date d'inscription
mercredi 11 octobre 2017
Statut
Membre
Dernière intervention
17 octobre 2017
-
Messages postés
12
Date d'inscription
mercredi 11 octobre 2017
Statut
Membre
Dernière intervention
17 octobre 2017
-
Bonjour,
j'ai un fichier dans lequel il y a un ensemble de données.
ce sont toutes des questions ou l'on répond par oui ou non.
ce fichier est dans ma 2éme feuille. en feuille 1, je reprends des scores finaux de plusieurs résultats.
ce sont toutes des moyennes.
évidement les moyennes "lisse" le résultat... mais la n'est pas le souci
je voudrais que chaque fois qu'un résultat est négatif, le faire apparaitre sur ma 1ère feuille. en gros, je voudrait connaitre une formule qui dit: si en feuille2 cellule C5 est différent de 0 copie le texte de feuille2 cellule B5 en feuille1 cellule C10.
un grand merciiiiiiii

4 réponses

Messages postés
591
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
19 juin 2020
49
Bonjour,

=SI(C5<>0;B5;"")
en français : si B5 différent de 0 alors valeur de B5 sinon rien
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
12
Date d'inscription
mercredi 11 octobre 2017
Statut
Membre
Dernière intervention
17 octobre 2017

Merci la formule fonctionne très bien. sauf que je voudrais que si en B5;C5;D5 est différent de 0 ou vide alors copie le texte de B6...
Messages postés
591
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
19 juin 2020
49
l'énoncé du problème a changé entre temps...

note que la demande n'est pas claire :

si en feuille2 cellule C5 est différent de 0 copie le texte de feuille2 cellule B5 en feuille1 cellule C10

si en B5;C5;D5 est différent de 0 ou vide alors copie le texte de B6.

donc si j'ai compris correctement, formule à entrer en C10 de la feuille 1 :

=SI(OU(ET(B5<>0;C5<>0;D5<>0);ET(B5="";C5="";D5=""));B6;"")



Messages postés
25543
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 novembre 2020
5 597
... et ce n'est toujours pas très clair!
faut il ne pas afficher B6 si à la fois B5,C,D5 contiennent un 0 et dans ce cas
:
=SI(NB.SI(B5:D5;0)=3;"";B6)

ou faut il ne pas afficher B6 lorsque'une des tris cellules contient un 0, et dans ce cas:

=SI(NB.SI(B5:D5;0);"";B6)

crdlmnt
Bonjour Toff8,

Je suis d'accord avec fabien25000,
ce que tu as écrit n'est pas clair !

----------------------

Pour ton 1er texte

Formule en Feuil1!C10 :

=SI(Feuil2!C5<>0;Feuil2!B5;"")

----------------------

Pour ton 2ème texte

Formule sur Feuil1 :

=SI(ET(Feuil2!B5<>0;Feuil2!C5<>0;Feuil2!D5<>0);Feuil2!B6;"")

----------------------

@fabien25000

a) tu as oublié les références à Feuil2

b) si en B5;C5;D5 est différent de 0 ou vide alors
    doit être compris comme suit (il me semble) :
    si en B5;C5;D5 est différent de (0 ou vide) alors

Cordialement
 
Messages postés
12
Date d'inscription
mercredi 11 octobre 2017
Statut
Membre
Dernière intervention
17 octobre 2017

Désolé pour la mauvaise explication,
en feuille 2 si B5 ou C5 ou D5 est différent de 0 alors afficher le texte de B6 dans C10 de la feuille 1. si vide ne rien afficher
J'espère que mon explication est plus clair
désolé et merci
Messages postés
25543
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 novembre 2020
5 597
alors, je répète

=SI(NB.SI(Feuil2!C5:B5;0)=3;"";Feuil2!B6)

crdlmnt
Messages postés
12
Date d'inscription
mercredi 11 octobre 2017
Statut
Membre
Dernière intervention
17 octobre 2017

Non désolé aucune de vos formule ne fonctione comme je le souhaite...
Je repete pour etre plus clair encore.
si mes cellules B5;C5;D5 sont à 0 ou vide feuille2=> feuille1 C10=vide
si l'une de ces 3 cellules sont + de 0 ou différente de vide alors afficher le texte de B6 qui se trouve en feuille2
 
Sur Feuil2 : B5, C5, D5, B6 ; sur Feuil1 : C10
alors formule en Feuil1!C10 :

=SI(NB.SI(Feuil2!B5:D5;">0")>0;Feuil2!B6;"")
 
Messages postés
12
Date d'inscription
mercredi 11 octobre 2017
Statut
Membre
Dernière intervention
17 octobre 2017
> jean
YESSSSSS MERCIIIIIII BCPPPPPPPP
>
Messages postés
12
Date d'inscription
mercredi 11 octobre 2017
Statut
Membre
Dernière intervention
17 octobre 2017

J'ai mieux : =SI(NB.SI(Feuil2!B5:D5;">0");Feuil2!B6;"")
Si c'est ok, merci de passer le sujet en résolu.  ;)
Messages postés
12
Date d'inscription
mercredi 11 octobre 2017
Statut
Membre
Dernière intervention
17 octobre 2017
> jean
Encore merci à tous