Variable "i" tel que Bi = B"1à300"

[Résolu/Fermé]
Signaler
-
 PLG17 -
Bonjour,

J'ai une liste de codes et à chaque code correspond une phrase.
Dans une nouvelle feuille, j'ai besoin de faire appel à ces informations.
L'idée serait de taper le code dans une cellule A2 et que dans la cellule A3 apparaisse la phrase.
Pour cela, j'ai trouvé la formule suivante, qui marche très bien :
A3=SI(A2=feuille1!B3;feuille2!C3;"")

Mon problème est que je souhaiterais pouvoir écrire A3=SI(A2=feuille1!B'i';feuille2!C'i';"") ou 'i' serait une variable de 1 à 300

Ainsi, si j'ai A2=feuille1!B255 j'aurais la phrase correspondante feuille2!C255

Merci d'avance pour votre aide,

PL

1 réponse

Messages postés
1429
Date d'inscription
lundi 13 juillet 2009
Statut
Membre
Dernière intervention
8 juin 2021
483
Salut,

Tu peux utiliser la fonction INDIRECT :

Ou ta variable i serait la cellule I1
=SI(A2=INDIRECT("feuille1!B"&I1);INDIRECT("feuille2!C"&I1);"")


Ainsi en changeant le nombre présent dans I1 alors automatiquement ton calcule va changer.
1f u c4n r34d th1s u r34lly n33d t0 g37 l41d !
Bonjour,

Merci Ozone pour le conseil. J'ai finalement résolu mon problème avec une formule "recherchev", mais je garde la formule que tu viens de m'apprendre en tête pour la prochaine fois.

Bonne journée,

PL