Selection de toutes lignes contenant un mot [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
samedi 4 avril 2015
Statut
Membre
Dernière intervention
4 avril 2015
-
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
-
Bonjour,

Désolée je suis nouvelle et peut-être pas très bonne mais j'avais une question.

J'ai un tableur qui se compose ainsi :

Date !! Heure !! "out" (ou "in") !! message

J'aurai voulu savoir comment sélectionner toutes les lignes contenant en troisième colonne "out" ou "in" pour changer la police de l'un d'une couleur et l'autre de l'autre.

Juste ne pas changer "out" ou "in" d'une couleur, mais toute la ligne les contenant.

Sachant que j'ai ÉNORMÉMENT de lignes, j'aimerai ne pas le faire ligne par ligne...

Merci d'avance !

5 réponses

Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 737
Bon jour
en supposant que votre colonne qui contient out ou in est la colonne C, à partir de la ligne 2 (à adapter)
sélectionnez tous le champ, de A2 à xxxx(?)
Ruban / onglet accueil/ mise en forme conditionnelle/ Nouvelle régle
dans la fenêtre: "utiliser une formule ....)
fenêtre suivante, entrez la formule:
=$C2="in"
(attention au signe $ qui permet de couvrir toute la ligne du champ
cliquez sur format/ formatez comme souhaité/cliquez sur OK et vous revenez à la fenêtre de MFC
/ Nouvelle fenêtre:
la formule:
=$C2="out"
format/formatez / et OK /OK

crdlmnt
4
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
2986
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
24 janvier 2021
413
Bonjour,

en faisant comme suit :
Tu selectionnes tout ton tableau et tu appliques une MFC

https://www.cjoint.com/c/EDemTTXfxeE
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 737
... et en complément
si vitre colonne "C" (?) contient du texte en complément de in ou out, la formule est:
=NB.SI($C2;"*in*") ou bien sur =NB.SI($C2;"*out*")
"*in*" si in peut être n'importe où dans le texte (mais fonctionne avec in dans n'importe quel mot, comme par exemple pain)
"in*" si in doit être au début
"*in" si in doit être à la fin<

Messages postés
2
Date d'inscription
samedi 4 avril 2015
Statut
Membre
Dernière intervention
4 avril 2015

Merci à vous deux ça marche impecc !!! :)
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 737
Pas de quoi, on passe le sujet en résolu
Bonne route
Crdlmnt

Errare humanum est, perseverare diabolicum