[edit] - Fatal error: Allowed memory size

Résolu
Bonjour
J'ai créé un portfolio avec jusqu'ici il fonctionnait bien et d'un seul coup le site me donne ce message


Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 2688 bytes) in /homepages/46/d344633703/htdocs/abdelgrich/wp-includes/default-constants.php on line 87

Merci pour votre aide.

2 réponses

  1. Modérateur
    Bonjour,

    Qu'as tu dans ton fichier /homepages/46/d344633703/htdocs/abdelgrich/wp-includes/default-constants.php ... à la ligne 87 ?

    1. C'est peut-être tout simplement que ton portfolio s'agrandit et que tu as besoin de plus de mémoire pour faire les traitements ...

      2 solutions :

      - Optimiser ton code pour que ça prenne moins de mémoire.
      - Augmenter la taille maximum de mémoire allouable :

      Php < à 5.3 :
      fichier php.ini à la racine de ton site
      memory_limit = 128M


      Php >= à 5.3
      fichier .user.ini à la racine de ton site
      memory_limit = 128M
      1. 128M ou 256M .. par défaut en général c'est 16M ou 32M. à toi de voir selon tes besoins et la capacité de ton serveur.
        Bien que dans ton cas on a l'impression que tu es limité à 262K .. ça me parait très léger.
      2. @Xavierdu34Merci Xavier pour ta réponse.
        En effet ma formule d'hébergement n'était adaptée.
        Mon hébergeur a fait le nécessaire pour la version php.
        En te remerciant
        Cordialement
        Abdel