Xterm failsafe session

Fermé
Funky76 Messages postés 24 Date d'inscription dimanche 20 janvier 2013 Statut Membre Dernière intervention 4 août 2016 - 3 janv. 2015 à 20:46
Funky76 Messages postés 24 Date d'inscription dimanche 20 janvier 2013 Statut Membre Dernière intervention 4 août 2016 - 10 janv. 2015 à 22:03
Bonjour,

je suis sur debian Wheezy et je n'arrive plus à avoir une session normale. Après avoir tapé mon mot de passe, une boîte de dialogue affiche "toutes les mises à jour ont été effectuées", puis une autre en anglais :

"I could not start your session and so i've started the failsafe Xterm session. Windows now have focus only if you have your cursor above them. To get out of this mode type 'exit' in the window in the uperleft corner"

ensuite je démarre direct sur un temrinal, sans la barre des tâches, ni l'heure ni rien en fait. Quand je tape 'exit', rebelotte avec mon mot de passe les fenêtres en français puis en anglais etc.

C'est sûrement dû aux manips précédentes que j'ai faites qui sont :

- installer les pilotes de ma carte graphique nvidia comme indiqué là https://wiki.debian.org/fr/NvidiaGraphicsDrivers

- après avoir constaté des bugs graphiques (notamment vim inutilisable à cause d'une espèce de "lag" graphique), j'ai décidé de désinstaller les pilotes nvidia comme indiqué sur https://askubuntu.com/questions/41681/blank-screen-after-installing-nvidia-restricted-driver
apt-get remove --purge nvidia* xserver-xorg-video-nouveau xserver-xorg-video-nv

- comme j'avais vu que le dossier /etc/X11 avait été créé uniquement lors de l'installation des pilotes nvidia, je l'ai supprimé (comme il fallait de toute façon supprimer le xorg.conf...)

J'ai cru que ça venait de gdm3 mais apt-get me dit qu'il est bien installé et à jour. Je ne sais pas quoi faire...

4 réponses

Utilisateur anonyme
4 janv. 2015 à 02:23
Salut,

Tapes les commandes suivantes dans une interface en ligne de commande :

sudo apt-get update
sudo apt-get purge --reinstall xserver*
reboot -f


Note : une connexion Internet est nécessaire.

Funky76 Messages postés 24 Date d'inscription dimanche 20 janvier 2013 Statut Membre Dernière intervention 4 août 2016 2
4 janv. 2015 à 12:55
bonjour,

j'ai tapé les commandes, et quand j'ai redémarré, plus aucune interface graphique ne fonctionnait : j'ai du taper mon login à la main dans un terminal plein écran, de même que mon mot de passe. Ensuite, plus moyen d'ouvrir une page internet par exemple...

Donc je me suis dit que peut-être il suffisait de réinstaller gdm3 et gnome-desktop-environment, ce que j'ai fait, mais je me retrouve avec le même problème que dans mon premier post...
Re,

On peut normallement reconstruire l'environnement graphique de base en tapant la commande suivante :

sudo dpkg-reconfigure xserver-xorg


On peut aussi le réinstaller (même si tu as déjà essayé de le faire) dans son ensemble si la première commande n'a aucun effet :

sudo apt-get install --reinstall xserver-xorg


Après avoir redémarré, tu peux aussi tenter de taper cette comande pour lancer xserver :

startx


Ou :

sudo service gdm start


Regarde aussi du côté du mode Recovery de GRUB pour voir s'il n'y a pas une option pour réparer ton système.

Il faut tout essayer, il y a forcément une solution.

« Il faut être tel que l'on n'ait pas à rougir devant soi-même. »
de Baltasar Gracian y Morales
Funky76 Messages postés 24 Date d'inscription dimanche 20 janvier 2013 Statut Membre Dernière intervention 4 août 2016 2
5 janv. 2015 à 22:00
Alors j'ai réessayé les commandes :

apt-get purge --reinstall xserver*
dpkg-reconfigure xserver-xorg
apt-get install --reinstall xserver-xorg

plusieurs fois dans tous les ordres possibles et inimaginables, rien n'y fait. Les commandes startx et service gdm start qui n'avaient rien changé auparavant ne sont même plus reconnus par le terminal (même en root). En gros quand je supprime xserver* j'ai plus aucune interface graphique, (je dois réinstaller gdm3 et gnome pour aller sur internet) et les autres commandes ont pas fait grand-chose.

J'ai noté une erreur supplémentaire au démarrage :

[failed] Could not start /usr/sbin/acpi_fakekeyd

ça c'est depuis le --reinstall xserver-xorg. Et quand je réinstalle des paquets comme gdm3 et gnome il vient pendant l'installation :

Could not start /etc/menu-methods/twm : abandon
erreut d'état 1
Impossible d'ouvrir /etc/X11/twm//system.twmrc-menu

Et en effet, dans mon dossier /etc/X11, il n'y a que :

app-defaults/ default-display-manager twn/ X Xsession.d/

Pour le GRUB, je sais pas comment faire...
Utilisateur anonyme
5 janv. 2015 à 22:47
Il faudrait m'indiquer les erreurs, un petit dmesg pourrait aussi aider. J'ai vu que startx était issue du paquet xorg-xinit (installe le) et refais un startx. Peut être en réinstallant le driver nvidia et repasser sur nouveau. J'ai également vu que l'erreur could not start pourrait être résolu en passant à gdm2.
0
Funky76 Messages postés 24 Date d'inscription dimanche 20 janvier 2013 Statut Membre Dernière intervention 4 août 2016 2 > Utilisateur anonyme
6 janv. 2015 à 21:54
J'ai essayé de réinstaller les drivers nvidia, mais ça n'a rien changé, donc je les redésinstallés... Pour xorg-xinit, apt-get ne le trouve pas, est-ce un paquet pour version stable ? De même gdm2 n'est pas dans mes dépôts (même contrib et non-free). Pour dmesg, j'ai 862 lignes d'output, il y a un grep quelque chose qui pourrait t'aider plus spécifiquement ?
0
Utilisateur anonyme
6 janv. 2015 à 22:16
C'est un 64 bit ?
0
Funky76 Messages postés 24 Date d'inscription dimanche 20 janvier 2013 Statut Membre Dernière intervention 4 août 2016 2 > Utilisateur anonyme
6 janv. 2015 à 22:31
Non 32
0
Bon, désinstalles xorg et gdm dans leurs totalités, utilises autoremove et purge. Redémarres. Ensuites, ajoutes deb http://ftp.fr.debian.org/debian/ wheezy main dans /etc/apt/sources.list avec nano (root). Puis installes le paquet xorg, mesa-utils puis installes gnome-core. Redémarres et fais un startx pour voir. Tu peux aussi passer par ces liens : https://packages.debian.org/wheezy/i386/xorg/download et https://packages.debian.org/wheezy/i386/gnome-core/download pour les télécharger.
0