Ajouter une durée si la cellule contient du texte [Résolu/Fermé]

Signaler
-
 logas -
Bonjour,


Dans la colonne B15 j'ai une heure au format 15:55 ==> 0.10416 correspond à 15 min en plus sur excel.
Dans la colonne A15 j'ai une date 04/11/2014
Dans la colonne C15 j'ai marqué ATU

Voici ma formule:

dans L15 j'ai tapé ça
=SI(C15="";"";SI(A15<>0;(B15+0,010416);""));SI(NB.SI(C15;"*ATU*");B15+0,041664;"")

Je souhaite donc que lorsque je marque quelque choses dans C15 excel m'incrémente l'heure de 15 min dans la cellule L15.
Puis si dans la cellule C15 je tape ATU excel m'incrémente de 1h

Cependant elle ne fonctionne pas : excel marque #VALEUR!

Doit passer par une macro ?? si oui lesquels??

merci de votre aide.

2 réponses

Messages postés
5492
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
14 août 2020
469
Bonjour

Essayer cette formule

=SI(C15="";"";SI(NB.SI(C15;"ATU");B15+1/24;SI(A15<>0;(B15+1/24/4);"")))


Merci beaucoup, ça fonctionne parfaitement a+++