Nombre de valeurs (sans doubles) correspondant à un critère

[Résolu/Fermé]
Signaler
Messages postés
37
Date d'inscription
lundi 31 janvier 2011
Statut
Membre
Dernière intervention
24 septembre 2016
-
Messages postés
37
Date d'inscription
lundi 31 janvier 2011
Statut
Membre
Dernière intervention
24 septembre 2016
-
Bonjour,

J'aimerai pouvoir savoir le nombre de valeur (et non d'occurrence) en fonction d'un critère.
J'ai dans la colonne A un critère (Texte), et dans la colonne B des valeurs (texte) qui sont souvent en double.

Exemple :
Correct 1
Correct 2
Correct 2
A faire 4
A faire 5
Correct 3

Je voudrai une cellule qui en choisissant comme critère "Correct" me retourne 3 (= 3 valeurs corrects, sans les doubles)

Bien sûr, je ne peux pas supprimer les doublons ni même trier les données ni ajouter des colonnes intermédiaires car le but et de le faire sur 5 ou 6 critères différents.

La formule matricielle suivante, si elle était correct répondrait totalement à mon besoin :
=SOMME(1/NB.SI(SI(A2:A14="Correct";B2:B14);SI(A2:A14="Correct";B2:B14)))-1

Je décortique :
SI(A2:A14="Correct";B2:B14)
Me permet d'avoir une matrice avec seulement les valeurs correspondant au critère, soit pour mon exemple : {1;2;2;FAUX;FAUX;3}

En faisant
=SOMME(1/NB.SI(<matrice précédente>;<matrice précédente>) me permet de compter le nombre de valeurs sans doublon et le "-1" d'enlever la valeur "FAUX".

Ces deux points marchent bien séparément mais impossible de les concaténer ! Il me retourne "VALEUR!", je pense du à mes matrices flottantes.

J'ai beaucoup essayé avec Nb.Si et Nb.Si.Ens sans résultat...

Help !

1 réponse

Messages postés
13114
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
14 octobre 2021
2 261
Bonsoir

Essaye la formule matricielle de Jacques Boisgontier
=NB(1/FREQUENCE(SI(A2:A14="Correct";B2:B14);B2:B14))

Cdlmnt
Messages postés
37
Date d'inscription
lundi 31 janvier 2011
Statut
Membre
Dernière intervention
24 septembre 2016
3
Bonjour,

Merci pour cette solution ! Le seul problème étant que mes données de la sélection B2:B14 doivent être au format nombre..
Mais bon je vais pouvoir faire avec avec une seul colonne intermédiaire (au bon format)

Merci
Messages postés
37
Date d'inscription
lundi 31 janvier 2011
Statut
Membre
Dernière intervention
24 septembre 2016
3
Et pas besoin de nouvelle colonne, il suffit d'utiliser CNUM() !!

Encore merci