Coordonnées d'une cellule comportant un texte spécifique

Résolu/Fermé
Signaler
-
 cerev -
Bonjour,

Je travaille actuellement sur un tableur dans lequel j'ai en ligne 1 (à partir de B1) un calendrier (du 01/08/2014 au 31/12/2014) et en ligne 2 et suivantes on peut avoir pour chaque date les termes "prévu", "traité" ou rien.

je souhaiterais ajouter dans la colonne A si possible une formule, sinon une macro qui me permettrait d'afficher dans cette colonne la date (ou les coordonnées) de la 1ere cellule en partant pas la gauche de la ligne en question comportant le texte "prévu".

après plusieurs recherches, j'ai essayé de combiner les fonctions DECALER, INDIRECT, ADRESSE et EQUIV mais cela ne me permet pas d'afficher la date de la 1ere cellule "prévu" en partant de la gauche et cette formule réagit également mal lorsque je modifie les termes des cellules (passage de prévu à traité, ajout ou suppression d'une case prévu ou traité)

j'espère être clair, je peux vous transmettre un fichier en exemple si vous le souhaitez.

merci par avance pour votre aide

2 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
543
Bonjour,

Tu peux essayer
=SIERREUR(INDEX($B$1:$EX$1;;EQUIV("prévu";$B$2:$EX$2;0));"")

A+
Nickel, ça fonctionne très bien!

merci beaucoup