Calc : Nombre de lignes d'un filtre [Résolu/Fermé]

Signaler
Messages postés
17994
Date d'inscription
dimanche 29 octobre 2006
Statut
Contributeur
Dernière intervention
7 juin 2020
-
Messages postés
25197
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 juillet 2020
-
Plop,

Je n'arrive pas à trouver comment connaître de manière simple le nombre de ligne suite à un filtrage.

Exemple, dans mon hôtel je veux connaître tous les départs aujourd'hui.
Je prends donc sur une semaine par exemple du 20/03 au 27/03.

J'ai environ 5.000 lignes donc je "autofiltre" ma première ligne et restreint en départ du 27/03/2014

Là j'ai uniquement tous mes départ du 22/03, mais comment avoir le nombre de ligne ?
Sous Excel, ça met dis en bas à gauche genre : "125 enregistrements sur 5300"

Une idée ?
Merci

1 réponse

Messages postés
25197
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 juillet 2020
5 379
Bonjour
pour avoir le nombre de départ du 27/03 sans filtre, si on suppose que toutes les lignes ont une date
à adapter
en colonne A de ligne 2 à 5000, les dates et en B1 la date cherchée
en C1 la formule
=NB.SI(A2:A5000;B1)
vous donnera le nombre de lignes avec la date de B1 en A
et donc le nombre de lignes filtrées

crdlmnt

Errare humanum est, perseverare diabolicum
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57401 internautes nous ont dit merci ce mois-ci

Messages postés
17994
Date d'inscription
dimanche 29 octobre 2006
Statut
Contributeur
Dernière intervention
7 juin 2020
2 861
Merci pour ce retour je testerai ça :)
Messages postés
17994
Date d'inscription
dimanche 29 octobre 2006
Statut
Contributeur
Dernière intervention
7 juin 2020
2 861
ça marche merci même si c'est pas des plus simple.

pour infos, on peut taper la valeur, voilà :
=NB.SI(Q2:Q1341;"19/03/2014")
Messages postés
25197
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 juillet 2020
5 379
Alors pour avoir plus directement le nombre de ligne filtrées, vous pouvez utiliser une colonne hors champ dans laquelle vous placez la formule, par exemple en colonne Z
=SI(A1="";1;0)
et la tirer sur la hauteur du champ
elle affichera 1 sur chaque ligne où vous placez une valeur quelconque en A
Ensuite, au dessus de la ,ligne de filtrer, vous placez cette formule

=SOUS.TOTAL(9;Z10:Z5000)

qui vous donnera le nombre de 1 visible après le filtrage

crdlmnt