PhpMyAdmin ne fonctionne plus

Fermé
cs_Driven Messages postés 9 Date d'inscription samedi 12 août 2006 Statut Membre Dernière intervention 12 septembre 2013 - 11 sept. 2013 à 20:19
mamiemando Messages postés 32096 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 1 février 2023 - 14 sept. 2013 à 00:30
Bonsoir,

J'ai installé suphp sur centos 6.4 en 32-bit et depuis le phpmyadmin ne fonctionne plus.

- Le titre de la page phpmyadmin est comme ça:

phpMyAdmin <?php echo PMA_VERSION; ?> - <?php echo htmlspecialchars($HTTP_HOST); ?>

- Le corps de la page phpmyadmin marque ceci:

Not Found

The requested URL /phpmyadmin/navigation.php< was not found on this server.

- Le tutoriel que j'ai utilisé est celui-ci:
http://phreek.org/blog/2012/03/install-suphp-on-centos-6

Je n'arrive pas à résoudre ce problème.
J'ai tenté de réinstaller phpmyadmin mais le résultat reste le même.
PHP fonctionne partout sauf sur phpmyadmin...

Pouvez-vous me venir en aide s'il vous plait ?

Je vous remercie par avance.
Cordialement,



--

3 réponses

mamiemando Messages postés 32096 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 1 février 2023 7 539
11 sept. 2013 à 20:38
La manière dont est structurée la configuration apache2 diffère un peu sous redhat et debian, mais dans l'idée, rien n'empêche d'adapter la configuration que tu as actuellement pour qu'elle se comporte de manière similaire.

Sous debian phpmyadmin est configuré au niveau apache grâce au fichier /etc/apache2/conf.d/phpmyadmin.

Il fichier est inclu depuis /etc/apache2/apache2.conf grâce à la directive suivante :
http://www.control-escape.com/web/configuring-apache2-debian.html

Include /etc/apache2/conf.d/[^.#]*

Une fois cette directive ajoutée, il suffit de créer le fichier /etc/apache2/conf.d/phpmyadmin, par exemple en s'inspirant de :
https://artduweb.com/tutoriels/phpmyadmin

# phpMyAdmin default Apache configuration

Alias /phpmyadmin /var/www/phpmyadmin

<Directory /var/www/phpmyadmin>
Options Indexes FollowSymLinks
DirectoryIndex index.php

# Authorize for setup
<Files setup.php>
# For Apache 1.3 and 2.0
<IfModule mod_auth.c>
AuthType Basic
AuthName "phpMyAdmin Setup"
AuthUserFile /etc/phpmyadmin/htpasswd.setup
</IfModule>
# For Apache 2.2
<IfModule mod_authn_file.c>
AuthType Basic
AuthName "phpMyAdmin Setup"
AuthUserFile /etc/phpmyadmin/htpasswd.setup
</IfModule>
Require valid-user
</Files>
<IfModule mod_php4.c>
AddType application/x-httpd-php .php

php_flag magic_quotes_gpc Off
php_flag track_vars On
php_flag register_globals Off
php_value include_path .
</IfModule>
<IfModule mod_php5.c>
AddType application/x-httpd-php .php

php_flag magic_quotes_gpc Off
php_flag track_vars On
php_flag register_globals Off
php_value include_path .
</IfModule>
</Directory>

Enfin, il ne reste plus qu'à relancer apache2 pour qu'il tienne compte de cette nouvelle configuration, en lançant une de ces deux commandes :

/etc/init.d/apache2 restart
service apache2 restart

Bonne chance
0
cs_Driven Messages postés 9 Date d'inscription samedi 12 août 2006 Statut Membre Dernière intervention 12 septembre 2013
Modifié par cs_Driven le 12/09/2013 à 19:56
Bonjour,

mamiemando je ne comprend pas trop désolé...

Je n'arrive pas à comprendre dû pourquoi suphp me fait plus fonctionner phpmyadmin.

Je n'arrive pas à résoudre ce problème, je me tourne vers les forums et pas moyen de ce faire aider...

Je suis dans la mouïse complet...

Il doit bien avoir une solution pour résoudre !?

:(

Cordialement,
--
0
mamiemando Messages postés 32096 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 1 février 2023 7 539
14 sept. 2013 à 00:30
Sans message d'erreur difficile à dire, déjà je ne suis pas persuadé que suphp soit nécessaire pour faire fonctionner phpmyadmin. Ce que je te recommande c'est de réinstaller proprement phpmyadmin à partir d'un paquet comme proposé ici :
http://www.prestaopen.com/linux/installation-de-phpmyadmin-sur-centos.html

Bonne chance
0