Problème avec les Fonctions rechercheV et Indirect

[Résolu/Fermé]
Signaler
Messages postés
185
Date d'inscription
vendredi 6 juillet 2012
Statut
Membre
Dernière intervention
27 août 2016
-
Messages postés
185
Date d'inscription
vendredi 6 juillet 2012
Statut
Membre
Dernière intervention
27 août 2016
-
Bonjour, à tous

j'ai un tableau de suivi des consommations mensuelle des huiles dans un atelier dons les mois sont étalés sur chaque onglet du classeur Excel 2007. De janvier -octobre voir le fichier ci-dessous comme exemple concret.

https://www.cjoint.com/?0JsmvzlNEgt

Mon problème est que je veux visualiser les données de chaque mois en étant dans le premier onglet que j'ai nommé "Consommation 2012", c'est pourquoi j'ai utilisé les fonctions RECHERCHEV, INDIRECT ET COLONNE tout en plaçant la syntaxe suivante dans la cellule B9 =RECHERCHEV(A9;INDIRECT(B4);COLONNE();FAUX), avant j'ai nommé tout les tableaux par rapport au nom des onglets, les noms des mois et ensuite j'ai crées une liste déroulante dans la cellule B4 et également fais une MFC pour la couleur de fond sur chaque mois, donc l'ojectif est que à chaque choix du mois dans la liste, les données de celui-ci s'affiche dans ce tableau.

Merci de m'aider, apparemment j'ai réussit de le faire sur les données de la section PL sur la cconsommations des huiles 30 dans la cellule B9, mais quand j'incrémente puis bouton droit de la souris et je choisie de copier les valeurs sans la mise en forme, dans autres cellules il m'affiche #REF! .

Que faire pour afficher les bons résultats dans d'autres cellules sans utilisé la macro?

Je crois que je me suis fais comprendre puisque s'expliquer n'est pas chose facile et je vous demande des excuses du fait que j'ai été peut être trop long.

Abientôt

A voir également:

2 réponses

Messages postés
10003
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
29 juillet 2021
2 163
bonjour

essaies ceci en B9
RECHERCHEV($A9;INDIRECT($B$4);COLONNE();FAUX)

bonne suite
Messages postés
185
Date d'inscription
vendredi 6 juillet 2012
Statut
Membre
Dernière intervention
27 août 2016

merci beaucoup, pourtant avant j'avais bloqué les cellules en les mettons en valeurs absolus.

ça marché Bravo et grand Merci!!
Messages postés
26121
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 juillet 2021
5 998
Bonjour
c'est la solution CCM81 pas de problème.
Toutefois on signale à yvespeter que ça ne fonctionnera pas sur Octobre, car le tableau est décalé d'une colonne vers la droite par rapport aux mois précédents.(commence en B au lieu de A.
Recaler le tableau ou changer les adresses dans le nom OCTOBRE
crdlmnt
Messages postés
185
Date d'inscription
vendredi 6 juillet 2012
Statut
Membre
Dernière intervention
27 août 2016

Merci à tous pour votre aide

c'est très bon, j'en suis très reconnaissant et flatter également

A +