Recherchev et si imbriqué [Fermé]

Signaler
Messages postés
327
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
18 janvier 2021
-
Messages postés
5550
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
21 avril 2021
-
Bonjour à tous,

excel 2007

j'ai besoin d'une formule qui imbrique recherchev et si => suivant la catégorie d'un salariée (a OU b ou c) correspond une grille de coefficient et à l'interieur de cette grille le coef augmente suivant le nombre d'annee d'ancienneté exemple
categorie A 3 ans d'ancienneté = 396
categorie B 3 ans = 411...

http://cjoint.com/data/0JkqqeEZ8fr_copie_de_bjhrqxlhknx_classeur1.xls

je n'y arrive pas quelqu'un peut il m'aider

merci beaucoup

steph
A voir également:

3 réponses

Messages postés
5550
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
21 avril 2021
594
Bonjour

voici une formule a mettre en C3 et a tirer sur la hauteur de vos lignes

=SI(A3="a";RECHERCHEV(B3;$H$3:$I$9;2;FAUX);RECHERCHEV(B3;$K$3:$L$9;2;FAUX))
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
327
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
18 janvier 2021
5
bonjour philou,

merci bcp pour ta formule qui marche, mais j'ai besoin d'une version un peu differente car en fait j'ai 5categories d'employés... comment puis je la modifier ? merci
Messages postés
9731
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
22 avril 2021
2 086
et s'il y a une catégorie c
=SI(A3="a";RECHERCHEV(B3;$H$3:$I$9;2;0);SI(A3="b";RECHERCHEV(B3;$K$3:$L$9;2;0);"a voir"))
où "à voir" est à compléter SI(A3="c"; .....)

bonne suite
Messages postés
327
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
18 janvier 2021
5
bonjour ccm81

merci pour ta formule ca marche super !!!!! merci beaucoup a vous et a tous de votre aide !!!
Messages postés
2466
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
20 avril 2021
962
Bonjour,
Pour une autre façon de voir les choses:
https://www.cjoint.com/?BJkrJAo5nx8
Messages postés
327
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
18 janvier 2021
5
merci tontong,

je ne connais pas du tout ce genre de formule mais je vais la travailler elle me servira ! merci pour ton aide

stephanie
Messages postés
5550
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
21 avril 2021
594
Une solution avec une table et rechercheH et rechercheV imbriquées
le lien

https://www.cjoint.com/?3JktjjW74Z2