Compter des valeur "texte" dans excel 2007 [Résolu/Fermé]

Signaler
Messages postés
93
Date d'inscription
lundi 6 octobre 2008
Statut
Membre
Dernière intervention
24 janvier 2014
-
Messages postés
17243
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 octobre 2020
-
Salut les amis !

Mon titre est un peu confus, mais j'ai une réelle question sur un sérieux problème
qui lui n'est pas confus, laissez moi vous l'expliquer :

Admettons que de la cellule A1 à la cellule A5 je crée un tableau.
Imaginons maintenant que dans la cellule A2 et A4 j'écrive le mot "saucisse"

et bien, est-il possible et avec quel moyen d'afficher
par exemple dans la cellule C1 combien de fois le mot "saucisse apparait dans mon tableau, Ici le résultat Dans C1 serait : 2.

J'espère que vous comprendrez mon petit soucis et ma demande.
Et pour toutes vos réponses je vous remercie d'avance.

Cordialement,

Nico

4 réponses

Messages postés
17243
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 octobre 2020
4 285
Salut,

Plusieurs possibilités, comme celle ci

=NB.SI(A1:A20;"saucisse")

ou
=NB.SI(A1:A20;"*saucisse*")

on peut également faire avec SOMMEPROD
9
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
93
Date d'inscription
lundi 6 octobre 2008
Statut
Membre
Dernière intervention
24 janvier 2014
3
Re les Helpeurs !

Bon tout compte fait je remet mon problème en "non-résolu" parce que suite à sa résolution, j'ai eu un petit soucis , je m'explique.

Tout content d'avoir réussi grâce à Mike-31 d'appliquer la formule :
=NB.SI(A1:A20;"*saucisse*") dans mon tableau EXCEL chez moi,
je me suis rendu à mon boulot pour ouvrir le tableau que j'avais mis en place à la maison avec cette petite formule. Mais là .... Cela ne marche plus.

En fait au boulot je n'ai pas EXCEL , mais j'ai OPENOFFICE CALC et apparemment
celui-ci ne comprend pas les ** qui se trouvent dans la formule.

du coup je peux seulement me servir que de la formule simple :
=NB.SI(A1:A20;"saucisse")

ce qui m'embête un peu puisque cette fonction de recherche approché grâce au
** me convenait tout à fait.

En clair, est ce que quelqu'un saurait comment mettre en oeuvre sur CALC
la formule =NB.SI(A1:A20;"*saucisse*") pour qu'elle fonctionne comme dans EXCEL.

Merci d'avance pour toutes vos réponses à tous.

Nico
Messages postés
93
Date d'inscription
lundi 6 octobre 2008
Statut
Membre
Dernière intervention
24 janvier 2014
3
SUPER !!!! Exactement ce que je voulais . Je te remercie, et je "plussois" parce que tu me donnes deux solutions excellente :

la 1er : =NB.SI(A1:A20;"saucisse")
--> qui additionne seulement les mots exactes recherchés

et la 2eme : =NB.SI(A1:A20;"*saucisse*")
--> qui additionne tout les mots commençant par "saucisse" ou comportant le mot "saucisse" )

TOUT SIMPLEMENT MERCIIIII !

Je clôture en résolu .

Nico
Messages postés
17243
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 octobre 2020
4 285
Re,

Alors je te conseille de remettre cette discussion en résolue et relancer une nouvelle concernant open office que je connais mal ensuite nous verrons comment trouver la charnière entre les deux applications.
Fais mois signe lorsque tu auras ouvert cette nouvelle discussion que je la suive

essaye tout de même ceci avec un point devant et après l'étoile

=NB.SI(A1:A20;".*saucisse*.")
ou ceci
=SI(NB.SI(A1:A20;".*saucisse*.")=0;NB.SI(A1:A20;"*saucisse*");NB.SI(A1:A20;".*saucisse*."))

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.