Compter le nombre de valeurs différentes dans 1 colonne EXCEL [Résolu/Fermé]

Signaler
-
 JMPt31 -
Comment faire pour pouvoir compter le nombre de valeurs (chiffres et/ou mots) différentes dans une même colonne EXCEL ?
Ces mots et/ou chiffres peuvent être du style :
- dans la colonne A : PRODUCTION, DEGRADE ou DEPANNAGE
- dans la colonne B : N° DE CODE en chiffres uniquement
- dans la colonne C : VISSEUSE, CLE DEBRAYABLE ou TOURNE-VIS
- dans la colonne D : P123456789, N987654321, Z000000000, P999999999, etc...
ou cellule vide
- dans la colonne E : N1E052, N1C2Q1, N5B0JX, etc...
ou cellule vide
- dans la colonne F : MONTER..., SERRER..., VISSAGE..., FIXER..., etc...
ou cellule vide
- dans la colonne G : 4, 8, 12, etc...
ou cellule vide
- dans la colonne H : 1PP1A99Z, 1PP2Z99A, etc...
ou cellule vide.

Merci d'avance pour votre aide.
Daniel.

2 réponses

Messages postés
17139
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 juillet 2020
4 127
Bonjour,

tu détailles 8 colonnes de A à H et tu veux compter les valeurs un seule fois dans une colonne, LA QUELLE !

un exemple de formule matricielle pour pour une plage colonne A
exemple de A2 à A50

=SOMME(SI(A2:A50<>"";1/NB.SI(A2:A50;A2:A50)))

Attention, une formule matricielle se confirme en cliquant en même temps sur 3 touches du clavier Ctrl, Shift et Entrée
si tu fais bien la formule se placera entre ce genre d'accolade {}
16
Merci

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez Comment Ça Marche

CCM 61974 internautes nous ont dit merci ce mois-ci

Simple et efficace. Merci !
C'est magique !!
Félicitation, cela m'a bien aidé.
Messages postés
2842
Date d'inscription
mercredi 11 février 2009
Statut
Contributeur
Dernière intervention
9 juillet 2020
147
Bonjour,

En général, je copie-colle la colonne ailleurs et fait Données -> Supprimer les doublons. Ensuite je sélectionne toutes les cases et ça me donne le nombre.