Excel Utilisation RechercheV et Indirect

Résolu/Fermé
Latrix
Messages postés
5
Date d'inscription
jeudi 9 février 2012
Statut
Membre
Dernière intervention
13 juillet 2012
- 9 févr. 2012 à 09:25
Latrix
Messages postés
5
Date d'inscription
jeudi 9 février 2012
Statut
Membre
Dernière intervention
13 juillet 2012
- 9 févr. 2012 à 11:58
Bonjour,


Je souhaite effectuer une recherche V sur une plage de cellule d'une autre feuille non générique. Pour cela, j'utilise la formule suivante :

=RECHERCHEV(I6;INDIRECT("'"&F6&"'!A5:G100");7)

- I6 contient la valeur à rechercher
- F6 contient le nom de la feuille sur laquelle faire la recherche
- A5:G100 : la plage où je souhaite rechercher la valeur en F6
- 7 la colonne que je souhaite récupérer

Mon problème est que cette formule me renvoie systématiquement la colonne 7 de la dernière ligne de la plage.
(exemple si je mets G50 à la place de G100, je récupère la colonne 7 de la ligne 50 alors que la valeur à rechercher se trouve en G25).

Par avance, merci pour votre aide.

6 réponses

michel_m
Messages postés
16574
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
3 août 2022
3 277
Modifié par michel_m le 9/02/2012 à 11:51
re,
=RECHERCHEV(I6;INDIRECT("'"&F6&"'!E5:G100");3;0)

recherchev "recherche" (...) dans la première colonne à gauche du tableau source;comme tu avais marqué A5:G100, il ne trouvait pas "rallongement" d'où le sinistre NA
Michel
8