Somme rechercheV excel [Fermé]

Signaler
Messages postés
107
Date d'inscription
mercredi 16 avril 2008
Statut
Membre
Dernière intervention
1 janvier 2013
-
 qumale07 -
Bonjour,

Dans un doc excel j'ai deux colonnes, une date et l'autre avec des valeurs, comme ceci:

Date / Valeur
10/03/12 100
20/03/12 300
01/04/12 250

J'aimerais avoir une formule qui ferait la somme des valeurs du mois de mars. Avec une recherchev ça me renvoi une valeur mais ce n'est pas la somme, pouvez vous m'aider?

Merci


8 réponses

Messages postés
16393
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
12 août 2020
9 621
Bonjour,

Ah oui, la RECHERCHEV recherche une seule valeur, donc pas de somme.

Utilise plutôt un SOMMEPROD :

=SOMMEPROD((MOIS(A2:A4)=3)*B2:B4)

m@rina
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57822 internautes nous ont dit merci ce mois-ci

Messages postés
17161
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 août 2020
4 170
Salut,

exemple, colonne A entre A2 et A20 les dates , entre B1 et B20 les valeurs
soit dans la formule tu saisis le numéro du mois (pour mars 3)
=SOMMEPROD((MOIS(A2:A20)=3)*B2:B20)
ou tu saisis ex. en F2 le numéro du mois ou tu crées une liste déroulante et tu fais référence à cette cellule
=SOMMEPROD((MOIS(A2:A20)=F2)*B2:B20)
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57822 internautes nous ont dit merci ce mois-ci

Messages postés
107
Date d'inscription
mercredi 16 avril 2008
Statut
Membre
Dernière intervention
1 janvier 2013
13
Merci a vous deux, la deuxieme solution doit etre la bonne vu que je veux faire une synthese par mois, et donc il y aura des colonnes faisant ref au mois. J'essaie, apres
Messages postés
17161
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 août 2020
4 170
Re,

Pour compléter les propositions, en F2 tu crées une liste de validation pour choisir le mois en toute lettre (janvier, février etc ...) qui sera converti en chiffre dans la formule qui sera

=SOMMEPROD((MOIS(A2:A20)=MOIS(1&F2))*B2:B20)
Messages postés
107
Date d'inscription
mercredi 16 avril 2008
Statut
Membre
Dernière intervention
1 janvier 2013
13
Si j'ai mis la liste des mois en format date exemple: mars-12, avril-12.... je pense pas avoir ce probleme si ?
Messages postés
107
Date d'inscription
mercredi 16 avril 2008
Statut
Membre
Dernière intervention
1 janvier 2013
13
J'ai besoin de cibler l'année aussi, comment je peux le rajouter ?
Messages postés
340
Date d'inscription
samedi 16 août 2008
Statut
Membre
Dernière intervention
20 novembre 2016
66
Sinon,

dans ton tableau, tu rajoutes 2 colonnes en C "ANNEE" avec la formule en C2 =annee(A2) et en D "Mois" avec la formule en D2 =mois(A2). Puis poignée de recopie vers le bas.

Ensuite tu fais un tableau croisée dynamique avec la plus grande sélection possible, avec en champ page ANNEE, en champs lignes MOIS et en champs de données somme de VALEUR.


Voilà
Messages postés
107
Date d'inscription
mercredi 16 avril 2008
Statut
Membre
Dernière intervention
1 janvier 2013
13
Voila j'ai fait comme ça, merci mais dans le tableau croisé, ça me mets des lignes de vides et donc vu que je fais une moyenne ça fausse tout
Messages postés
340
Date d'inscription
samedi 16 août 2008
Statut
Membre
Dernière intervention
20 novembre 2016
66
Dans les options des champs, tu peux filtrer les lignes vides
Messages postés
107
Date d'inscription
mercredi 16 avril 2008
Statut
Membre
Dernière intervention
1 janvier 2013
13
j'avais vu cette option mais ça n'a rien changer pour moi
Bonjour
j'ai suivi ta méthode et je pense que ça devrait fonctionner.
J'ai fait la fonction suivante =(RECHERCHEV(Feuil2!A1;données;2))+A1 ou données est mon tableau d'entrée.
Merci
Messages postés
17161
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 août 2020
4 170
Re,

Si en F2 par exemple tu saisis le mois et l'année ou que tu crées une liste de validation avec ce type d'affichage en A2 à A20 par exemple tes dates et en B2 à B20 tes valeurs
cette formule predra en compte l'année et le mois de F2

=SOMMEPROD((ANNEE(A2:A20)=ANNEE(E4))*(MOIS(A2:A20)=MOIS(E4))*B2:B20)

si tu veux un montage fait signe