[excel] formule de soustraction

[Résolu/Fermé]
Signaler
-
 GIGI -
Bonjour,

Question sur une soustraction toute simple.

J'ai une formule à écrire pour effectuer la soustraction du total d'une colonne (de la cellule C3 à C7) avec celui d'une autre colonne (de la cellule E3 à la cellule E7). Si j'effectue dans un premier temps le total de la première colonne dans une case (C9) et dans une autre le total de la deuxième colonne (E9), la formule suivante fonctionne très bien : =C9-E9

Mais j'aimerais savoir si l'on est obligé de passer par cette méthode.

En effet je ne comprends pas pourquoi, si je marque :
=(C3:C7)-(E3:E7), cela ne fonctionne pas, car cette formule me semble tout à fait compréhensible.

Quelqu'un pourrait-il m'aider à comprendre ce qui ne va pas dans cette formule?
Merci d'avance!!!

2 réponses


Il faut écrire : =somme(c3:c7)-somme(e3:e7)
107
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

et moi je ne comprends pas comment on fait 10 moins 2 je n'arrive a trouver 8 !!!!!!
Messages postés
54337
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2021
16 326
Si dans une cellule tu saisis "10 moins 2" c'est une phrase en format texte, et Excel (ni personne) ne peut deviner que tu avais l'intention de demander à effectuer une opération sur des valeurs numériques !
Mais ce n'est pas que de l'étourderie, j'en ai peur ...
merci du tuyau !
Merci pour ce petit tuto, qui m'a bien remémoré cette formule.
Messages postés
113942
Date d'inscription
mardi 6 septembre 2005
Statut
Membre
Dernière intervention
28 août 2020
3 252
Salut,

Regarde sur ce lien
http://www.admexcel.com/guides/e9701.htm

A++
Merci beaucoup marie pour ce lien, il m'aidera certainement pour d'autres choses! C'est un bon pense bête, mais je n'y ai pas trouvé ma réponse. Faut que je regarde mieux, j'ai peut-être zappé quelque chose.
Merci encore et bonne journée.
Si jamais tu as trouvé, ça m'intéresse également, chaque fois que je met =SOMME(C2-B2) ou =SOMME(C2:C6)-SOMME(B2:B6) il me met "valeur"
Messages postés
54337
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2021
16 326 > titi
Pas la peine de mettre =SOMME(C2-B2) ; il suffît d'écrire =C2-B2
Mais si B2 ou C2 contient un texte, il est normal que s'affiche le message d'erreur #VALEUR!