Aide Excel - compter nombre d'occurence [Résolu/Fermé]

Signaler
Messages postés
12
Date d'inscription
vendredi 1 septembre 2006
Statut
Membre
Dernière intervention
26 janvier 2010
-
 Huburbe -
Bonjour,

j'aurais besoin d'aide, j'ai un petit souci en excel...

J'ai une fusion de colonne (B, C, D) sur la ligne 1, dans cette fusion, j'ai le mot Lundi (ainsi de suite pour les autres jours de la semaine).

Dans la ligne 2, en B2, j'ai TB. En C2, j'ai S. En D2, j'ai I. (la même chose pour les autres jours de la semaine).

Ensuite, en A3, j'ai Toto et en A4, j'ai Titi.

Je donne des côtes aux différentes personnes (mettre une croix dans la case correspondant à la côte. Par exemple, un TB le lundi pour Toto, un I le lundi pour Titi... )

Je voudrais compter le nombre différent de TB, S, I que chaque personne a eu sur la semaine.


En espérant avoir été assez clair.

Merci d'avance

10 réponses

Il y a plus simple ^_^ : il suffit de mettre la commande suivante !

=NB.SI(A0:A8;"*BRA*")

les * permettent de remplacer n'importe quoi dans la chaine de caractère.
83
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60959 internautes nous ont dit merci ce mois-ci

Bonjour ça marche mais si dans plage de cellule j'utilise ctrl pour prendre plusieurs cellules ça m'affiche #valeur en solution hélp me :(
Miraculeux, je n'avais pas mis les étoiles du coup il ne comptait que les réponses contenant UNIQUEMENT le mot entre " " et ne prenait pas en considération le même mot repris dans une liste
Merci WIZARD!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Merci ! Merci !! Merci !!!
source: "http://forum.hardware.fr/hfr/WindowsSoftwareReseaux/Logiciels/excel-compteur-occurence-sujet_249479_1.htm"


>>> Mais si je veux compter le nombre de fois qu'apparait "BRA" dans un grand nombre de cellule, je suis plutot mal. En plus, il est possible que le texte que je cherche, ici "BRA" soit qu'un partie du contenu de la cellule. Typiquement, si dans une cellule, j'ai "BRA, GLE", je veux que ca me le compte. La par contre, je ne sais pas comment faire, surtout que la cellule peut aussi bien contenir differents mots qu'être vide.

Nabou
Mon p'tit bout d'chou...
Posté le 30-03-2006 à 13:40:09

Utilise la fonction NB.SI

benratti
Posté le 30-03-2006 à 15:01:09

Ok, je te remercie, ca fait a peut pret ce que je veux. J'ai donc la formule suivante :
=NB.SI(M2:M49;"BRA" )

Ca me permet bien de compter le nombre de cellule dont le contenu est "BRA". Par contre, je ne vois pas comment faire pour tester non pas que le contenu de la cellule soit egal, mais que le contenu contienne le mot que je recherche.


Nabou
Mon p'tit bout d'chou...
Posté le 30-03-2006 à 15:16:52

J'ai eu ce besoin il y a quelque temps et j'ai utilisé pour détecter une chaine quelconque la formule suivante : =SI(CHERCHE($D$2;B4);"OK";"" ) (tu mets ce que tu veux à la place de D$B$) en fait, sur chaques lignes, j'ajoute ce test et en fin de tableau sur la colonne de résultat j'utilise NB.SI pour compter le nb de résultat concluant, c'est un peu lourd mais ça fonctionne

Message édité par Nabou le 30-03-2006 à 15:24:01
Bonjour,
J'ai un autre problème pour compter aussi, je m'éxplique imaginons
en A1 j'ai = 12+15+13
en A2 j'ai =35+24
En A3 j'ai rien
en A4 j'ai = 45

Et je souhaiterai une formule qui compte le nombre de valeur total, ici la réponse souhaitée serait "6".
y'a t'il une formule pour cela?

Je vous remerci
Messages postés
23761
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020
2 885
Pas de formule simple, puisqu'il faut analyser le contenu de chaque cellule...
merci pour l'info
pour bra dans un mot tu tapes NB.SI(plagecellule;"*BRA*") ca incrementera tous les mots contenant BRA
Messages postés
23761
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020
2 885
Salut,

tu peux voir la fonction nb.si, qui compte le nombre de cellules d'une plage donnée qui ont une valeur donnée...
Ex :
=NB.SI(A1:A50,"TB")
--
A+ Blux
 "Les cons, ça ose tout.
C'est même à ça qu'on les reconnait"
Messages postés
12
Date d'inscription
vendredi 1 septembre 2006
Statut
Membre
Dernière intervention
26 janvier 2010
1
Merci pour vos réponse, mais je ne crois pas que vos solutions fonctionnent dans mon cas.
Car je ne mets pas de TB dans les cases, mais je mets une croix.

TB, S, I sont des entêtes de colonnes.
ah ? je ne le savais pas.
à ce moment, il faudrait "viser" les cases de la colonne concernée (j'imagine que vous avec une colonne tb, une colonne s et une i
donc à ce moment: faites une case "resultat tb" qui vise les cases de la colonne tb, un e case resultat s etc...

correction par rapport à blux: il faut mettre ; pas , dans la parenthese de formule.
Pour ma par ce qui a marché c'est =NB.SI(C2:C122;"oui"), si ça peut aider certains, va compter tous les oui pour la plage C2 à C122 ;)

Voili voilou
Combien de fois trouve-t-on la lettre N (le contenu de A9) dans la cellule C2

=NBCAR(SUBSTITUE($C$2;$A9;"WW"))-NBCAR($C$2)

Le formule remplace les N par WW, et compte les caractères
Elle déduit le nb de caractères de la cellule à l'origine.
S'il y avait 23 caractères dont 5 N à l'origine, il y a 28 caractères dont 10 W à la fin.
La différence 28 - 23 = 5 donne le nb de N in dans la cellule d'origine.
Bonjour,

bien que je n'est pas trouve de solution aucune de ces formules est correcte
salut,

une petite question :
j'ai créé un tableau avec deux feuilles,
dans le premier tableau une liste d'article avec une colonne "E" ou je veux mettre un "x"
pour qu'il me renvois la ligne dans le tableau de la deuxième feuille en A:B mais sans sauter de
ligne à chaque fois.
comment puis-je faire SVP
Merci de votre réponse

René
Bonjour, envoyez moi votre fichier excel svp par mail harlock59@gmail.com
> Alf-Red
Bonjour Alfred!

Peut tu me dire stp si tu as trouvé une solution à ton problème, car je suis dans la même situation...

"En plus, il est possible que le texte que je cherche, ici "BRA" soit qu'un partie du contenu de la cellule. Typiquement, si dans une cellule, j'ai "BRA, GLE", je veux que ca me le compte."

Cordialement

Poisson
> poisson
Salut tout le monde, je réponds...1an après tout le monde ou 2ans cela dépend ^^

J'ai testé la solution > =NB.SI(F6:F48; "x") et magie elle fonctionne ^^


Voili voilou, enfait entre les crochets c'est une chaine de caractères donc et bien nous pouvons mettre ce que nous souhaitons...Genre "tatayoyo" ou autre ^^

Tchou bisous :)
Bonjour.

J'ai trouve une solution mais seulement pour une version en anglais de MS Office :

=COUNTA(Xn1:Xn2) <- Je crois comprendre que tu voudrais connaitre le nb de x dans une colonne (j'espere avoir bien compris le truc).
Bonsoir à tous,

J'aurais besoin d'aide pour un tableau de disponibilité.

Je m'explique
feuille N°1 :j'ai un tableau d'archivage ( fais sur Base d'une macro (composer comme tel: Numéro de facture en A1, Nom du client en B1, Prénom en C1 des période en D1 et en E1 le nom de la maison)

Feuille N° 2 : j'ai un tableau avec le titre de mes colonne c'est le nom de mes maison et le titre de mes ligne est les périodes.

J'aimerais que sur base de ma feuille d'archivage (période et Nom de maison) un croix se met dans mon tableau en feuille 2.
J'espère avoir était claire si pas dites moi.

je vous remercie d'avance de votre aide !!!
Messages postés
23761
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020
2 885
La clarté serait la bienvenue en écrivant un tant soit peu un français cohérent...
Je ne sais pas si vous avez lu la réponse que j'ai mis au dessus, mais elle doit être valable normalement sachant qu'elle prend en compte les chaînes de caractères.
Bonjour;

A la place de la plage de recherche de NB.SI, je cherche à mettre un numéro de ligne définit sur une autre cellule.

Cordialement