Couleur de case comme condition openoffice [Résolu/Fermé]

Signaler
-
 Errius -
Bonsoir,

pardonnez moi d'avance si la question a déjà été posée, mais je n'ai pas trouvé de réponse.

Je n'y connais hélas rien en tableur open office mais :

j'aurais voulu savoir si la couleur de remplissage d'une case peut être une condition mise dans une formule.
Je m'explique :

J'ai fait un tableur relativement simple, type agenda, dans lequel j'ai mis, à coté de chaque horaire, le montant à payer par le patient.
Je remplis en rouge si le patient n'a pas payer (il payera à la prochaine consultation), et en vert si il a payer.
A droite de mon tableau, j'ai une formule classique de somme, pour la fin de la journée, et une autre pour les recettes cumulée journalière. Recettes fictives, car, évidemment, une partie des patient n'a pas encore payer.
Je voudrais faire une formule qui me dise, à côté des mes résultats théoriques, un truc du genre :
la somme non payée (soit le total des cases rouges) est de XX euros.
la somme payée (là, c'est plus facile : total théorique moins total cases rouges).

Si une telle formule n'existe pas, c'est bête, mais je ne vois pas comment faire.
Auriez vous quelques alternatives ?
Même si je dois avouer que j'ai vraiment un faible pour mon simple système de cases de couleurs... je suis du genre visuel. donc si la formule existe, je la veux bien.

Merci d'avance !


A voir également:

5 réponses

Messages postés
53600
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
11 avril 2021
15 648
NON.
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Bonjour
Plus simplement, utilisez une colonne Payé avec un pointage par code , par exemple OK qui vous permettra facilement de compter les payés (OK ) et les non payés!
=SOMME.SI(champ code;"OK";champ montant)
avec une validation dans les cellules codes, c'est encore plus pratique que de changer les couleurs!

si vous tenez à votre rouge et vert, vous pouvez passer par une mise en forme conditionnelle qui passera les cellules montants et pointage en rouge, dés qu'un montant est entré en cellule montant et en vert quand le montant est pointé payé par OK. avec un OK dans le même vert que le remplissage, il ne se verra même pas!

crdlmnt



Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
merci Vaucluse pour votre réponse.
j'a effectivement opté pour un code à coté du payement, c'est vrai que c'est efficace.
en tout cas merci pour vos explications, certains se contentent de mettre "non", je vois pas très bien l'intérêt de ce type de réponse...
merci encore !
Messages postés
53600
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
11 avril 2021
15 648
Je me permets tout de même de rappeler la question : "j'aurais voulu savoir si la couleur de remplissage d'une case peut être une condition mise dans une formule".
Il m'a semblé que OUI n'étant pas la réponse, je ne pouvais répondre que NON !
Cette exigence a été confirmée et explicitée plus loin "Je voudrais faire une formule qui me dise, à côté des mes résultats théoriques, un truc du genre :
la somme non payée (soit le total des cases rouges) est de XX euros.
la somme payée (là, c'est plus facile : total théorique moins total cases rouges)
".
Une telle formule n'existe pas. Je voulais que ce soit clair.
Et c'est bien pourquoi mon ami Vaucluse s'est trouvé dans l'obligation de sortir du schéma de la demande pour proposer une toute autre approche ...

On est d'accord ?
Bonjour,

Réponse qui date un peu, mais c'est pour ceux qui tombe sur le sujet cherchant une solution pour faire la somme de cellules selon leur couleur de fond.

Par des formules c'est possible bien qu'un peu compliqué en utilisant les styles de formatage et la fonction CELLULE.

Exemple:

1) Déterminer un style pour chacune de vos cellules de couleurs en incluant un format de nombre avec 1, 2 ou 3 décimales (exemple vert->background: vert et nombre: #,0 ; rouge -> background: rouge et nombre: #,00 ...)

2) Appliquez les styles aux cellules concernées

3) créez un second tableau (T1) faisant référence à votre tableau d'origine (T0) (par exemple à la ligne 3), avec la formule suivante :
=CELLULE("format";A1)&T(ALEA())

Cela vous retournera F0, F1, F2 ou F3 selon le nombre de décimal après la virgule de la cellule A1, respectivement 0, 1 , 2 et 3.
T(Alea()) est là juste pour forcé le re calcul de la cellule après une quelconque modif.

4) ensuite vous créez un troisième tableau (T2) faisant référence au tableau précédent T1 (par exemple à la ligne 5) et insérer la formule :
=SI(a3="F1";A1;0)
qui sera donc égal à 0 sauf si la cellule a un fond vert
=SI(a3="F2";A1;0)
qui sera donc égal à 0 sauf si la cellule a un fond rouge

5) vous n'avez plus qu'à faire la somme des cellules concernés de ce dernier tableau T2 pour faire la somme des cellules vertes du tableau d'origine T0.
=somme(a1:a999)

On peu améliorer, mais voila un exemple du principe.

Note: si vous voulez simplement calculer les cellules d'une certaine couleur, même principe mais faite la somme du tableau T1 avec la formule suivante :
=SOMMEPROD(A1:A999="F1")
pour la couleur verte.
=SOMMEPROD(A1:A999="F2")
pour la couleur rouge.

En espérant que cela puisse aider certain.