[openvpn] démarrage et connexion automatique

Résolu/Fermé
Signaler
Messages postés
66
Date d'inscription
jeudi 6 janvier 2005
Statut
Membre
Dernière intervention
28 décembre 2015
-
Messages postés
174
Date d'inscription
mardi 31 juillet 2007
Statut
Membre
Dernière intervention
6 avril 2020
-
Bonjour a tous
j'ai mis en place un vpn entre 2 machines distantes avec Openvpn et cela fonctionne nickel MAIS...
comme vous le savez + on mache les choses pour les mieux c'est pour eux et j'aimerais qu'au démarrage de windows openvpn se lance (ca c'est déjà ok) et que la connexion se lance automatiquement
j'ai trouvé cela dans la doc d'openvpn

If you want OpenVPN GUI to start a connection automatically when it's started,
you can use the --connect cmd-line option. You have to include the extention
for the config file. Example:
openvpn-gui --connect office.ovpn

ce qui si je comprends bien ferai ce que je demande mais je ne comprends pas comment lui claquer cette ligne de commande ?
si des personnes comprennent mieux que moi ! merci
A voir également:

6 réponses

salut,

j'ai fait une petite manip pour l'automatisation :

* créer un raccourci sur le bureau qui pointe vers le fichier "openvpn-gui.exe"
* dans les propriétés de ce raccourci, modifier comme suit :
"C:\Program Files\OpenVPN\bin\openvpn-gui.exe" --connect monserver.ovpn 

* ensuite désactiver le lancement automatique d'openvpn (avec msconfig)
* rajouter ce raccourci dans "Démarrer, Programmes Démarrage"

et ca marche nikel :-)
7
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Bonjour,

il y a beaucoup plus simple sous XP,

demarer > Executer > regedit

chercher dans HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
"openvpn-gui" doucble cliquez et modifier la ligne "C:\\Program Files\\OpenVPN\\bin\\openvpn-gui.exe"
en

"openvpn-gui"="C:\\Program Files\\OpenVPN\\bin\\openvpn-gui.exe --connect client.ovpn"

cordialement

Xqua

Always your's
Messages postés
66
Date d'inscription
jeudi 6 janvier 2005
Statut
Membre
Dernière intervention
28 décembre 2015
5
ok j'ai réussi a faire ce que je voulais, c'est a dire un script bash placé dans le répertoir e"démarrage" et qui donc s'execute au démarrage de windows
MAIS
le seul pb c'est que la fenetre dos s'ouvre et lance openvpn, mais une fois la connexion effectuée la fenetre dos ne se ferme pas automatiquement
voici mon batch si des programmeurs passent par là !
_______________________________________________________
@echo off

echo ÉÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍ»
echo º º
echo º Mise en place de la connexion VPN. º
echo º Une fois la connexion initialisee º
echo º vous pouvez fermer cette fenetre º
echo º º
echo ÈÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍͼ

@openvpn-gui --connect monserver.ovpn
cls
_______________________________________________________

d'apres ce que j'ai vu le seul fait de mettre cls a la fin devrait me fermer la fenetre mais il n'en est rien (je suis sous XP)

@echo off

echo ÉÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍ»
echo º º
echo º Mise en place de la connexion VPN. º
echo º º
echo ÈÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍÍͼ

start /MIN openvpn-gui --connect monserver.ovpn

exit
Messages postés
178
Date d'inscription
samedi 25 février 2006
Statut
Membre
Dernière intervention
28 février 2013
11
j'ai un probleme pour demarer openvpn au en tant que services, sa marche tres bien en mode bridge mais j'ai qu'un seul pc sur le reseau que je veux acceder don faire un pont sa m'arrange pas trop surtout que le pc est en wifi (clez usb wifi), c'est pourquoi je l'ai laissais en mode routed.

le serveur est sous windows xp et j'ai mis le openvpn 2.1.
le montage du serveur ce fait parfaitement, demarre parfaitement avec le deamon mais pas avec le services de plus je suis confrontais
a un probleme de parefeu windows qui me bloque quand je veux acceder au partage qu'il y a sur le serveur, il suffit que je desactive le parfeu pour acceder au partage en tapant \\10.8.0.1 dans executer sinon je suis bloqué.

toute les route que j'ai fait ne change rien, si quellequ'un a une reponces a ces deux probleme je lui en serais tres reconnaissant.
Messages postés
178
Date d'inscription
samedi 25 février 2006
Statut
Membre
Dernière intervention
28 février 2013
11
e revient tres vite sur ce poste finalement car je viens de trouvé pourquoi le serveur ne demarré pas en tant que service, c'etait de ma faute a force de trifouillé le fichier de config j'avais decomenté la ligne faisant reference au serveur dhcp mais je ne resout pas le probleme pour acceder au partage qu'il y a sur le serveur, si vous avez une
idée.
c'est sur que sa vient du parfeu windows mais je ne comprend pas ce que j'ai oublier,
C:\Program Files\OpenVPN\bin\openvpn.exe et bien dans le parfeu, le partage de fichier est activé, j'ai ouvert le port au cas ou sa aurait un rapport mais je ne comprend pas.
j'ai vue qu'il y avait des route a faire donc pour les test sa ping du client au serveur et du server au client
je peux acceder au serveur par vnc avec l'adresse 10.8.0.1 a part le partage de fichier j'ai accé a tous doncje doute que ce soit dù a une route mais a partir du serveur je peux acceder au partage qu'il y a sur le client donc le le part feu windows ne bloque pas reelement des deux coté.
Est-ce que l'ont peux acceder au ressource du serveur quand ont est en mode routage sur openvpn.
merci.
Messages postés
174
Date d'inscription
mardi 31 juillet 2007
Statut
Membre
Dernière intervention
6 avril 2020
64
Créer un fichier bat
exemple : myvpn.bat

contenant

openvpn-gui client.opvn

Mettre un raccourcis du fichier bat dans Démarrage