Problème avec ifconfig, ping,... sous Unix [Résolu/Fermé]

Signaler
-
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
-
Salut a tous,
J'ai un petit souci avec le tcp/Ip sous unix. J'utilise une distribution linux, la version Aurox 11.0.

Quand jsuis sur un terminal de commande je n'arrive pas à lancer les utilitaire de configuration réseau à savoir ifconfig, ping, netstat, etc...

Ce n'est pas un problème de synthaxe, car je les connais bien, j'ai même essayé sur la distribution linux Mandriva, ça marche; mais sur ma distribution Aurox 11.0 ça ne marche pas, il me met 'ifconfig' commande inconnue, c'est pareil pour les autres...

Pourtant je me suis mis en mode super utilisateur avec la commande su.

Merci d'avance pour votre aide.

1 réponse

Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 544
Salut,

Pourtant je me suis mis en mode super utilisateur avec la commande su.

Essaies avec su -

Quand tu te connecte avec su tu es en root mais dans l'environnement d'utilisateur qui a exécuté la commande.
Quand tu fait su - tu es root dans l'environnement de root

[user@locahost ~]$ pwd
/home/user
[user@locahost ~]$ su
Password:
[root@locahost user]# pwd
/home/user
[root@locahost user]# exit
[user@locahost ~]$ pwd
/home/user
[user@locahost ~]$ su -
Password:
[root@locahost ~]# pwd
/root
[root@locahost ~]#
Maintenant tu peux tester la commande ifconfig
[root@locahost ~]# ifconfig