RECHERCHEV sous calc (openoffice) [Résolu/Fermé]

Signaler
-
 Pouloupe -
Bonjour, j'essayer de faire une recherche V suivante:

=RECHERCHEV(I9;feuille2.A1:A40;5;0)

I9 étant la valeur rechercher dans la colonne A de 1à 40.
J'aimerai que m'a fonction me renvoie la valeur de la 5 éme colonne situé dans la même ligne ou la valeur a été trouvé.

Ici je reçoi toujours 0 comme résultat.


4 réponses

Je pense que dans votre cas, il faut combiner les 2 formules suivantes : INDEX et EQUIV. =INDEX(EQUIV(........)).
Bon courage
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 287
Biensur on ne connait pas la disposition de ces données. Mais en partant la syntaxe de sa fonction RECHERCHEV n'est pas correcte.
=RECHERCHEV(cellule_lue ; tableau ; numéro_de_colonne) la plage de son tableau n'est surement pas A1:A40
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 287
Salut,

si ton tableau s'étend de A1 jusqu'à F40 ta formule devra être:
=RECHERCHEV(I9;feuille2!A1:F40;5;FAUX)

Voilà ;)
=RECHERCHEV(I9;feuille2.A1:E40;5;0)

Marche pour moi attention au ! par coontre je ne comprend pas à quoi correspond le 0 ou le FAUX a la fin de la formule.
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 287
=RECHERCHEV(cellule_lue ; tableau ; numéro_de_colonne ; valeur_proche)

L'argument valeur_proche peut prendre deux valeurs : VRAI, ou bien FAUX. Si l'argument est VRAI (ou 1), Excel prend la valeur inférieure la plus proche s'il ne trouve pas la valeur exacte. Si l'argument est FAUX (ou 0), Excel renvoie la valeur exacte, ou un message d'erreur s'il ne trouve pas de valeur exacte. Si l'argument est omis, Excel lui attribue par défaut la valeur VRAI.
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 287
Et en passant un "merci" n'a jamais fait de tord quand quelqu'un prends la peine de nous aider.

Merci
Messages postés
5296
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
17 août 2018
1 139
Bonjour !
FAUX : la recherche n'est PAS approximative, mais exacte :
1// pas nécessaire de trier ta zone de recherche A...
2// si pas trouvé, résultat = N/A

VRAI : la recherche est approximative
1// la zone doit être triée
2// si pas trouvé, c'est le résultat qui précède qui est renvoyé, donc pas nécessairement acceptable ..
Par contre, cela peut être intéressant dans le cas de tarifs par intervalles de valeurs ..

A+
Nyctaclope

PS :
Bonjour Ricky , je n'avais pas encore vu ta réponse ..
Le "merci" : tu n'es apparemment pas encore habitué au comportement de certains ?
N'oublie pas que pour beaucoup tu es un "robot répondeur" sans état d'âme ...
On ne remercie pas un parkmètre quand il a délivré son ticket :))
Bonne suite à toi ...
Merci pour vos réponses.