Formule RECHERCHEV et l'ami #N/D

Fermé
sork - 27 mars 2019 à 20:15
 sork - 23 avril 2019 à 22:31
Bonjour,
J'ai acutellement un problème avec cette formule RECHERCHEV.
En effet, lorsque j'éxecute celle-ci [=RECHERCHEV(H1;$Feuille32.A2:B56;2;1)]
Je devrai depuis ma référence H1 ( le chiffre 1), retrouver dans ma cellule, ce qui correspond à la feuille.32 correspondant au chiffre 1 qui se trouve dans la première case.
Je ne sais pas si vous me suivez, en tout cas, j'ai fait le tour de quelques forums avec un sujet s'approchant de ma situation. Je pensais qu'il aurait pu s'agir du formatage de la cellule nombre ; texte etc... mais ce n'est vraisemblablement pas ça.
Je vous ai donc laissé un exemple du sujet sur la feuille 6.
Seriez vous donc en mesure de m'expliquer la cause de mon problème que je puisse comprendre mes erreurs.
Merci d'avance

https://www.cjoint.com/c/ICBtnDW3icQ

Configuration: Windows / Chrome 72.0.3626.121

6 réponses

yclik Messages postés 3605 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 17 mai 2024 1 483
28 mars 2019 à 08:40
Bonjour

En A1 feuille 6 il ya :
=RECHERCHEV(H1;$Feuille32.A2:B56;2;1)
il faut
=RECHERCHEV(H1;$Feuille32.B2:C56;2;0)

en K1 feuille 6 il ya :
=RECHERCHEV(R1;$Feuille32.$A2:$Feuille32.$B78;2;1)
il faut :
=RECHERCHEV(R1;$Feuille32.$B$2:$C$78;2;0)

La plage de recherche A2:B56 n'est pas bonne, il faut la plage B2:B56
colonne B donne le nombre
colonne C donne la date
Donc rechercher le nombre dans la colonne B et renvoyer dans la 2ème colonne, de plage de recherche B2:C56, la date ( Col C sur la Feuille 32).

Le dernier argument de la fonction est à 1 il faut mettre à 0

Par contre le classeur me semble corrompu car en A1 feuille 6 je n'ai que l'affichage de la formule et non le résultat.
Peut être classeur d'origine excel ?
3
Bonsoir, il semblerait que j'ai toujours la même erreur.
En effet, dans la logique sur la feuille6 en A1 devrait figurer, selon la valeur en H1, la valeur se trouvant feuille32 en A2 etc...
Pouvez vous m'éclairer sur ce problème?

Effectivement j'ai un drôle de bug aussi. Pourtant je ne me rappelle pas avoir changé d'un xls à un odt....
Merci
0