Macros désactivées dans excel 2007 [Résolu/Fermé]

Signaler
Messages postés
139
Date d'inscription
mercredi 17 janvier 2007
Statut
Membre
Dernière intervention
11 mai 2010
-
 ANIS -


Bonjour,
Win XP avec office pro 2007
J'ai un classeur Excel avec des macros, un menu et un userform
Mon problème : impossible de lancer mes macros j'ai le message classique : en raison de vos paramètres de sécurité les macros ont été désactivées
Le classeur a été créé avec l'options des paramètres des macro : Activer toutes les macros (même si ce n'est pas prudent). J'ai utilisé ce classeur sur un PC Win XP office 2007 tout fonctionnait OK
Je change de PC (carte mère HS) je réinstalle mes licences sur le nouveaux je paramètre Excel de la même façon pour les macros cochant Activer les macros
Rien n'y fait : message : impossible de lancer mes macros
Y aurait-il un autre paramètre de sécurité qui m'aurait échappé

Accès approuvé au modèle d'objet du projet VBA j'ai mis mon dossier dans ce paramètre
Merci à ceux qui ont une idée et à tous de m'avoir lu avec patience

j'ai déjà posté ceci dans le forum excel-download (sans réponse)
https://www.excel-downloads.com/threads/macros-desactivees-malgre-que.140921/

Gilles

6 réponses

Messages postés
16425
Date d'inscription
vendredi 12 mai 2006
Statut
Contributeur sécurité
Dernière intervention
22 janvier 2014
1 353
Bonjour,

N'aurais-tu pas oublié un paramètre?

Ouvre un fichier excel => Outils => Macros => Sécurité et dans l'onglet "Sécurité" coche "Moyen"

Cordialement
Messages postés
139
Date d'inscription
mercredi 17 janvier 2007
Statut
Membre
Dernière intervention
11 mai 2010
22
merci hubertaaz
Ce que tu me proposes doit être en Excel 97 (2003) mais je suis en Excel 2007 (ms office pro 2007) et le menu outil macro n'exiset pas

Merci quand même
Messages postés
16425
Date d'inscription
vendredi 12 mai 2006
Statut
Contributeur sécurité
Dernière intervention
22 janvier 2014
1 353
En effet, j'ai Office 2003.

Peut-être une solution ici : http://web.hec.ca/virtuose/index.cfm?page=391#q3

ou ici : http://office.microsoft.com/fr-fr/powerpoint/HA100310711036.aspx
@+
Celui qui pose une question est bête cinq minutes, celui qui n'ose pas l'est toute sa vie.
(Proverbe chinois)
Messages postés
139
Date d'inscription
mercredi 17 janvier 2007
Statut
Membre
Dernière intervention
11 mai 2010
22
merci encore hubertaaz
J'ai regardé les liens que tu me donnes
Curieusement je n'ai jamais la barre des messages de sécurité qui apparait donc jamais le bouton options
pourtant dans les paramètres de sécurité j'ai bien laissé l'apparition de cette barre

Je vais chercher et encore chercher , en attendant j'ai résolu le problème par cette bidouille:

refaire un classeur tout neuf , importer mes 8 modules le userforme et le menu que j'avais pris soin d'exporter

Si je trouve je viendrai dire comment pour être utile à la communauté
Je ne voudrais pas abuser de ton temps
bon WE à tous
Gilles
Messages postés
16425
Date d'inscription
vendredi 12 mai 2006
Statut
Contributeur sécurité
Dernière intervention
22 janvier 2014
1 353
Merci pour l'info!

Ça serait effectivement sympa de communiquer la solution ici au cas où comme je l'espère tu la trouverais.

Bon WE à toi
Hubert
Messages postés
139
Date d'inscription
mercredi 17 janvier 2007
Statut
Membre
Dernière intervention
11 mai 2010
22
Finalement, aucune solution pour moi
Même en allant dans le registre vérifier les clefs , partout les macros sont bien activées
Alors la solution miracle c'est de repasser en xls (office 97)
Je pense même désinstaller 2007 car à part des gadget sois disants demandés par les utilisateurs, je ne vois pas les grandes avancées
Je note ce sujet comme résolu
Messages postés
16425
Date d'inscription
vendredi 12 mai 2006
Statut
Contributeur sécurité
Dernière intervention
22 janvier 2014
1 353
Bonjour Gilles,

Merci pour ces précisions.

Bonne journée.

Hubert
Bonjour.

J'utilise Excel 2010 et j'ai aussi été confronté à ce problème d'affichage du message "Les macros ont été désactivés" "Activer le contenu".

La solution pour éliminer ce message :

<Fichier> - <Options> - <Centre de gestion de la confidentialité> - bouton <Paramètres du Centre de gestion de la confidentialité> - <Paramètres des macros> - Parmi les 4 options cocher celle de "Activer toutes les macros"

Ca marche, mais évidemment ça laisse la porte ouverte aux macros malveillants. Donc à vos risques et périls!

HTH.

T-Phi
la solution est d'installé Suite Microsoft Office 2007 Service Pack 2 (SP2):
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=b444bf18-79ea-46c6-8a81-9db49b4ab6e5