Excel compter cellules [Résolu/Fermé]

Signaler
Messages postés
1
Date d'inscription
jeudi 18 août 2005
Statut
Membre
Dernière intervention
18 août 2005
-
 Reboot -
AU SECOURS !!
DANS UNE FEUILLE EXCEL COMMENT COMPTER LE NOMBRE DE CELLULE CONTENANT UN MOT (JE DIS BIEN CONTENANT, ENTRE AUTRE, UN MOT) LES CELLULES CONTENANT CE MOT SEUL OU CE MOT AVEC D'AUTRES OU UNE REFERENCE.
MERCI J'AI UN GROS PRBLÈME CAR PLUS DE 60 000 CELLULES.

4 réponses

Messages postés
414
Date d'inscription
samedi 30 juillet 2005
Statut
Membre
Dernière intervention
18 décembre 2005
189
Salut,

Pour compter un mot, la fonction "NB SI" devrait faire l'affaire.
Aide excel :
Supposons que la plage A3:A6 contienne, respectivement, « pommes », « oranges », « pêches », « pommes » :
NB.SI(A3:A6;"pommes") égale 2

Pour compter le nombre de cellules contenant un mot avec d'autres,
il faut utiliser le symbole générique "*".
Supposons que la plage A3:A6 contienne, respectivement, « pommes », « oranges », « pêches », « pommes », « Pêches abricot »
NB SI(A3:A6;"*pêches*") égale 2

Pour une référence, je ne sais pas.
132
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Merci aussi
Super parfait !
waw 9 ans!!! c fou!
Pour une référence, il faudra seulement ajouter un &, qui marque le changement de format

Exemple : si on veut compter le nombre de fois ou mes cellules contiennent le mot "pêches" + une valeur en D2 sur une plage A1:C50

=NB.SI(A1:C50;"*pêches*"&D2)
Question un poil + technique mais du même genre: pour compter le nombre de cellules NE CONTENANT PAS LE CHIFFRE ZERO, et dispersées sur plusieurs colonnes (pas sur une seule même plage de données A1:A7).
Messages postés
5939
Date d'inscription
mercredi 26 mai 2004
Statut
Contributeur
Dernière intervention
18 septembre 2009
209
une petite macro devrait faire ton affaire.
Est ce qu'il est possible d'appliquer ceci lorsque l'on veut faire une somme dans plusieurs feuilles Xls
Excellent!!
Merci pour cette super aide !!
Excellent!!
Merci beaucoup.
vraiment merci !!! EXCELLENT !!