Compter des cellules contenant du texte

[Fermé]
Signaler
-
 Kinda -
Bonjour,

J'aimerais pouvoir compter le nombre de cellules contenant un texte tout en évitant de compter une cellule deux fois si elle contient le même texte.
EX:
1 tartre
2 citron
3 tartre
4 véhicule
5 chaussures
Ainsi pour cette série j'aurai 4 cellules; c'est facile avec très peu de cellules mais quand on a une bonne centaine cela devient hardue!
Please help me j'en ai besoin urgemment
A voir également:

5 réponses

La vrai syntaxe est :

=NB.SI(B4:B22;"<>")
13
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42854 internautes nous ont dit merci ce mois-ci

Un tout grand merci
Bon j'ai pas le temps d'attendre ta réponse;

Mais sache que si c'est exel ou open office Calc, il existe la formule NB.SI(plage,"mot")

Donc tu peux essayer une des deux solution (je ne sais plus laquelle fonctionne, c'est peut etre différents selon le logiciel):

=NB.SI(A1:A50,"tarte") ou
=NB.SI(A1:A50,'citron')
Messages postés
82717
Date d'inscription
samedi 24 août 2002
Statut
Modérateur
Dernière intervention
2 septembre 2021
4 582
Ben euh .....

Non.
Là justement elle va compter les doublons.

Il faut juste compter les cellules qui ne sont pas vides .... Donc =NB.SI(A1:A50 <> "") (pas complètement certain de la syntaxe)
Dans un exel?
Messages postés
82717
Date d'inscription
samedi 24 août 2002
Statut
Modérateur
Dernière intervention
2 septembre 2021
4 582
Salut.

C'est avec quel logiciel ?????????????????