Porblèmle de Rewrite rule (htaccess)

Résolu
Bonjour,
j'ai un petit problème.
J'aimerais la règle à mettre dans le htaccess pour que mes urls commençant par http://monsite.com soient transformées en http://www.monsite.com.
Je pensais que
[code]
RewriteCond %{HTTP_HOST} ^inpal.com$
RewriteRule ^(.*) http://www.inpal.com/$1 [QSA,L,R=301]
[/code]
suffirait mais ce n'est pas le cas.
Configuration: Windows XP
Firefox 3.0

2 réponses

  1. Ton code est correcte, peut-être que ton hébergeur n'accepte pas l'url rewriting.
    0
    1. Merci, du coup j'ai pu chercher ailleurs la cause de mon erreur.

      Maintenant, ça marche, j'ai mis

      [code]

      RewriteBase /
      RewriteEngine on
      RewriteCond %{HTTP_HOST} ^inpal.com$
      RewriteRule ^(.*) http://www.inpal.com/$1 [QSA,L,R=301]

      [/code]
      0