Excel formul si compris entre x et y

Résolu/Fermé
Clairettededi - 12 juin 2011 à 14:35
 Ben - 2 avril 2018 à 13:54
Bonjour,

Je me trouve en difficulté pour utiliser la formule si sous excel 2003. En effet je souhaiterais appliquer : si age compris entre 12 et 16 = tarif de 255 si age compris entre 6 et 11 ans = un tarif de 133 et si l'age inférieur a 5 ans = un tarif de 0.

J'ai essayé d'appliquer la formule suivante : =SI((12>=J21<=16);255;SI((6>=J21<=11);131;0)) en sachant que J21 est l'age de l'enfant mais je n'obtient aucun résultat. Pouvez m'aider svp.

Merci d'avance

A voir également:

1 réponse

Ricky38
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 436
12 juin 2011 à 14:47
Salut,

=SI(J21="";"";SI(J21<6;0;SI(J21<12;133;SI(J21<=16;255;""))))
19
Clairettededi
12 juin 2011 à 14:59
Merci beaucoup pour cette solution.
0
Est t'il possible de faire la même formule pour 8 valeur ? J'ai essayer de modifier celle ci mais ca ne marche pas
0
Il vaut mieux passer par RECHERCHEV pour plusieurs valeurs
Ex:
Soit les 2 colonnes
A B
0 tarif 1
5 tarif 2
10 tarif 3
etc
en A les bornes des tranches d' âge en B les tarifs correspondants
Si en C1 on rentre un àge, par ex 6 avec en C2 la formule suivante
RECHERCHEV(C1;A1:B4;2;VRAI) où A1:B24 est la plage où trouver les données
C2 affichera alors tarif 2
0
Merci
0